Whamcloud - gitweb
LU-13197 e2fsck: avoid mallinfo() if over 2GB allocated
[tools/e2fsprogs.git] / e2fsprogs.spec
1 %define _root_sbindir   /sbin
2 %define _root_libdir    /%{_lib}
3 %define _root_localedir /usr/share/locale
4 %define _root_etcdir    /etc
5
6 Summary: Utilities for managing ext2/ext3/ext4 filesystems
7 Name: e2fsprogs
8 Version: 1.45.2.wc2
9 Release: 0%{_vendor}
10 License: GPLv2 and LGPLv2
11 Group: System Environment/Base
12 Source:  ftp://download.sourceforge.net/pub/sourceforge/e2fsprogs/e2fsprogs-%{version}.tar.gz
13 Url: https://downloads.whamcloud.com/public/e2fsprogs/
14 Prereq: /sbin/ldconfig
15 BuildRoot: %{_tmppath}/%{name}-root
16 %if %{_vendor} == "suse"
17 Group: System/Filesystems
18 Provides: e2fsbn ext2fs libcom_err = %{version} ldiskfsprogs = %{version}
19 Obsoletes: ext2fs libcom_err < %{version}
20 %else
21 Group: System Environment/Base
22 Provides: e2fsprogs-libs = %{version} ldiskfsprogs = %{version}
23 Obsoletes: e4fsprogs e2fsprogs-libs < %{version}
24 %endif
25
26 %description
27 The e2fsprogs package contains a number of utilities for creating,
28 checking, modifying, and correcting any inconsistencies in ext2, ext3,
29 and ext4 filesystems.  E2fsprogs contains e2fsck (used to repair
30 filesystem inconsistencies after an unclean shutdown), mke2fs (used to
31 initialize a partition to contain an empty ext2 filesystem), debugfs
32 (used to examine the internal structure of a filesystem, to manually
33 repair a corrupted filesystem or to create test cases for e2fsck),
34 tune2fs (used to modify filesystem parameters), resize2fs to grow and
35 shrink unmounted ext2 filesystems, and most of the other core ext2fs
36 filesystem utilities.
37
38 You should install the e2fsprogs package if you are using any ext2,
39 ext3, or ext4 filesystems (if you're not sure, you probably should
40 install this package).  You may also need to install it (even if you
41 don't use ext2/ext3/ext4) for the libuuid and libblkid libraries and
42 fsck tool that are included here.
43
44 %package devel
45 Summary: Ext2 filesystem-specific static libraries and headers.
46 Group: Development/Libraries
47 Requires: e2fsprogs = %{version}
48 Prereq: /sbin/install-info
49
50 %description devel
51 E2fsprogs-devel contains the libraries and header files needed to
52 develop ext2, ext3, or ext4 filesystem-specific programs.
53
54 You should install e2fsprogs-devel if you want to develop
55 ext2. ext3. or ext4 filesystem-specific programs.  If you install
56 e2fsprogs-devel, you'll also want to install e2fsprogs.
57
58 %package -n uuidd
59 Summary: helper daemon to guarantee uniqueness of time-based UUIDs
60 Group: System Environment/Daemons
61 License: GPLv2
62 Requires: e2fsprogs = %{version}
63 Requires(pre): shadow-utils
64
65 %description -n uuidd
66 The uuidd package contains a userspace daemon (uuidd) which guarantees
67 uniqueness of time-based UUID generation even at very high rates on
68 SMP systems.
69
70 %prep
71 %setup
72
73 %build
74 %configure --enable-elf-shlibs --enable-nls --disable-defrag \
75         --enable-quota --disable-fuse2fs \
76         %{?extra_config_flags:%extra_config_flags}
77 make
78 make check
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 export PATH=/sbin:$PATH
83 make install install-libs DESTDIR="$RPM_BUILD_ROOT" \
84         root_sbindir=%{_root_sbindir} root_libdir=%{_root_libdir}
85 /sbin/ldconfig -n ${RPM_BUILD_ROOT}%{_libdir}
86
87 # Add a dir that uuidd needs that the Makefiles don't create
88 install -d $RPM_BUILD_ROOT/var/lib/libuuid
89
90 %find_lang %{name}
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post -p /sbin/ldconfig
96
97 %postun -p /sbin/ldconfig
98
99 %post devel
100 if [ -x /sbin/install-info -a -f %{_infodir}/libext2fs.info.gz ]; then
101     /sbin/install-info %{_infodir}/libext2fs.info.gz %{_infodir}/dir
102 fi
103 exit 0
104
105 %postun devel
106 if [ $1 = 0 -a -x /sbin/install-info -a -f %{_infodir}/libext2fs.info.gz ]; then
107    /sbin/install-info --delete %{_infodir}/libext2fs.info.gz %{_infodir}/dir
108 fi
109 exit 0
110
111 %pre -n uuidd
112 getent group uuidd >/dev/null || groupadd -r uuidd
113 getent passwd uuidd >/dev/null || \
114 useradd -r -g uuidd -d /var/lib/libuuid -s /sbin/nologin \
115     -c "UUID generator helper daemon" uuidd
116 exit 0
117
118 %files -f %{name}.lang
119 %defattr(-,root,root)
120 %doc README RELEASE-NOTES
121
122 %{_root_sbindir}/badblocks
123 %{_root_sbindir}/blkid
124 %{_root_sbindir}/debugfs
125 %{_root_sbindir}/dumpe2fs
126 %{_root_sbindir}/e2fsck
127 %{_root_sbindir}/e2image
128 %{_root_sbindir}/e2label
129 %{_root_sbindir}/e2mmpstatus
130 %{_root_sbindir}/e2undo
131 %{_root_sbindir}/findfs
132 %{_root_sbindir}/fsck
133 %{_root_sbindir}/fsck.ext2
134 %{_root_sbindir}/fsck.ext3
135 %{_root_sbindir}/fsck.ext4
136 %{_root_sbindir}/fsck.ext4dev
137 %{_root_sbindir}/logsave
138 %{_root_sbindir}/mke2fs
139 %{_root_etcdir}/mke2fs.conf
140 %{_root_sbindir}/mkfs.ext2
141 %{_root_sbindir}/mkfs.ext3
142 %{_root_sbindir}/mkfs.ext4
143 %{_root_sbindir}/mkfs.ext4dev
144 %{_root_sbindir}/resize2fs
145 %{_root_sbindir}/tune2fs
146 %{_sbindir}/filefrag
147 %{_sbindir}/mklost+found
148 %{_sbindir}/e2freefrag
149
150 %{_root_libdir}/libblkid.so.*
151 %{_root_libdir}/libcom_err.so.*
152 %{_root_libdir}/libe2p.so.*
153 %{_root_libdir}/libext2fs.so.*
154 %{_root_libdir}/libss.so.*
155 %{_root_libdir}/libuuid.so.*
156
157 %{_libdir}/e2initrd_helper
158
159 %{_bindir}/chattr
160 %{_bindir}/lsattr
161 %{_bindir}/uuidgen
162 %{_mandir}/man1/chattr.1*
163 %{_mandir}/man1/lsattr.1*
164 %{_mandir}/man1/uuidgen.1*
165
166 %{_mandir}/man5/e2fsck.conf.5*
167 %{_mandir}/man5/mke2fs.conf.5*
168 %{_mandir}/man5/ext2.5*
169 %{_mandir}/man5/ext3.5*
170 %{_mandir}/man5/ext4.5*
171
172 %{_mandir}/man8/badblocks.8*
173 %{_mandir}/man8/blkid.8*
174 %{_mandir}/man8/debugfs.8*
175 %{_mandir}/man8/dumpe2fs.8*
176 %{_mandir}/man8/e2fsck.8*
177 %{_mandir}/man8/findfs.8*
178 %{_mandir}/man8/fsck.ext2.8*
179 %{_mandir}/man8/fsck.ext3.8*
180 %{_mandir}/man8/fsck.ext4.8*
181 %{_mandir}/man8/fsck.ext4dev.8*
182 %{_mandir}/man8/e2image.8*
183 %{_mandir}/man8/e2label.8*
184 %{_mandir}/man8/e2mmpstatus.8*
185 %{_mandir}/man8/e2undo.8*
186 %{_mandir}/man8/fsck.8*
187 %{_mandir}/man8/logsave.8*
188 %{_mandir}/man8/mke2fs.8*
189 %{_mandir}/man8/mkfs.ext2.8*
190 %{_mandir}/man8/mkfs.ext3.8*
191 %{_mandir}/man8/mkfs.ext4.8*
192 %{_mandir}/man8/mkfs.ext4dev.8*
193 %{_mandir}/man8/mklost+found.8*
194 %{_mandir}/man8/resize2fs.8*
195 %{_mandir}/man8/tune2fs.8*
196 %{_mandir}/man8/filefrag.8*
197 %{_mandir}/man8/e2freefrag.8*
198
199 %files devel
200 %defattr(-,root,root)
201 %{_infodir}/libext2fs.info*
202 %{_bindir}/compile_et
203 %{_bindir}/mk_cmds
204
205 %{_libdir}/libblkid.a
206 %{_libdir}/libblkid.so
207 %{_libdir}/libcom_err.a
208 %{_libdir}/libcom_err.so
209 %{_libdir}/libe2p.a
210 %{_libdir}/libe2p.so
211 %{_libdir}/libext2fs.a
212 %{_libdir}/libext2fs.so
213 %{_libdir}/libss.a
214 %{_libdir}/libss.so
215 %{_libdir}/libuuid.a
216 %{_libdir}/libuuid.so
217
218 %{_libdir}/pkgconfig/blkid.pc
219 %{_libdir}/pkgconfig/com_err.pc
220 %{_libdir}/pkgconfig/e2p.pc
221 %{_libdir}/pkgconfig/ext2fs.pc
222 %{_libdir}/pkgconfig/ss.pc
223 %{_libdir}/pkgconfig/uuid.pc
224
225 %{_datadir}/et
226 %{_datadir}/ss
227 %{_includedir}/blkid
228 %{_includedir}/e2p
229 %{_includedir}/et
230 %{_includedir}/com_err.h
231 %{_includedir}/ext2fs
232 %{_includedir}/ss
233 %{_includedir}/uuid
234 %{_mandir}/man1/compile_et.1*
235 %{_mandir}/man1/mk_cmds.1*
236 %{_mandir}/man3/com_err.3*
237 %{_mandir}/man3/libblkid.3*
238 %{_mandir}/man3/uuid.3*
239 %{_mandir}/man3/uuid_clear.3*
240 %{_mandir}/man3/uuid_compare.3*
241 %{_mandir}/man3/uuid_copy.3*
242 %{_mandir}/man3/uuid_generate.3*
243 %{_mandir}/man3/uuid_generate_random.3*
244 %{_mandir}/man3/uuid_generate_time.3*
245 %{_mandir}/man3/uuid_is_null.3*
246 %{_mandir}/man3/uuid_parse.3*
247 %{_mandir}/man3/uuid_time.3*
248 %{_mandir}/man3/uuid_unparse.3*
249
250 %files -n uuidd
251 %defattr(-,root,root)
252 # if you want to run via init
253 # /etc/init.d/uuidd
254 %{_mandir}/man8/uuidd.8*
255 %attr(6755, uuidd, uuidd) %{_sbindir}/uuidd
256 %dir %attr(2775, uuidd, uuidd) /var/lib/libuuid
257