Whamcloud - gitweb
Merge branch 'maint' into next
[tools/e2fsprogs.git] / debian / rules
index cc73333..d3e2494 100755 (executable)
@@ -92,13 +92,11 @@ STD_CONF_FLAGS = --with-ccopts="${CCOPTS}" --enable-compression \
                --enable-blkid-devmapper
 
 BF_CONF_FLAGS = --with-ccopts="${CCOPTS} ${BF_CCOPTS}" \
-       --disable-nls --disable-swapfs --disable-imager \
+       --disable-nls --disable-imager \
        --disable-debugfs  --disable-e2initrd-helper
 
 MIPS_NOPIC_CONF_FLAGS = --with-ccopts="${CCOPTS}" \
-       --disable-nls \
-       --disable-swapfs --disable-imager \
-        --disable-resizer # --disable-debugfs
+       --disable-nls --disable-imager --disable-resizer # --disable-debugfs
 
 # we can't use those flags at configure time
 MIPS_CFLAGS= -G 0 -fno-pic -mno-abicalls
@@ -191,8 +189,8 @@ ${BUILDBFSTAMP}: ${CFGBFSTAMP}
 clean:
        dh_testdir
        rm -rf ${STAMPSDIR}
-       -make -C ${stdbuilddir} -i distclean
-       -make -C ${bfbuilddir} -i distclean
+       [ ! -f ${stdbuilddir}/Makefile ] || make -C ${stdbuilddir} distclean
+       [ ! -f ${bfbuilddir}/Makefile ] || make -C ${bfbuilddir} distclean
        rm -rf ${stdbuilddir} ${bfbuilddir} ${mipsbuilddir} ${mipsbuilddir64}
        rm -f doc/libext2fs/*.html lib/et/com_err/*.html debian/*.substvars
        dh_clean
@@ -342,6 +340,12 @@ binary-arch: install install-udeb
 
        $(INSTALL) -d ${debdir}/uuid-dev/usr/share/doc/libuuid${UUID_SOVERSION}
 
+       if test -f /etc/lsb-release && \
+               grep -q DISTRIB_ID=Ubuntu /etc/lsb-release; then \
+       $(INSTALL) -p -m 0644 e2fsck/e2fsck.conf.ubuntu \
+               ${debdir}/e2fsprogs/etc/e2fsck.conf; \
+       fi
+
        dh_installinfo -pcomerr-dev ${stdbuilddir}/lib/et/com_err.info
        dh_installinfo -pe2fslibs-dev ${stdbuilddir}/doc/libext2fs.info
 
@@ -350,6 +354,7 @@ binary-arch: install install-udeb
                -plibss${SS_SOVERSION} -plibuuid${UUID_SOVERSION} \
                -pe2fslibs -puuid-dev -pe2fsck-static
 
+       dh_fixperms
 ifneq ($(ismips),)
        dh_strip -Xlib64ext2fs-nopic.a
 else
@@ -357,7 +362,6 @@ else
 endif
 
        dh_compress
-       dh_fixperms
 
        dh_makeshlibs -Ne2fsprogs-udeb -Nlibblkid1-udeb -Nlibuuid1-udeb
        dh_makeshlibs -plibcomerr${COMERR_SOVERSION} \