Whamcloud - gitweb
debugfs: decode and dump xattrs on inode stat
[tools/e2fsprogs.git] / e2fsprogs.spec
1 %define _root_sbindir   /sbin
2 %define _root_libdir    /%{_lib}
3 %define _root_localedir /usr/share/locale
4 %define _root_etcdir    /etc
5
6 Summary: Utilities for managing ext2/ext3/ext4 filesystems
7 Name: e2fsprogs
8 Version: 1.47.1
9 Release: 0%{_vendor}
10 License: GPLv2 and LGPLv2
11 Source:  ftp://download.sourceforge.net/pub/sourceforge/e2fsprogs/e2fsprogs-%{version}.tar.gz
12 Url: https://downloads.whamcloud.com/public/e2fsprogs/
13 BuildRoot: %{_tmppath}/%{name}-root
14 %if "%{_vendor}" == "suse"
15 Group: System/Filesystems
16 Provides: e2fsbn ext2fs libcom_err = %{version} ldiskfsprogs = %{version}
17 Obsoletes: ext2fs libcom_err < %{version}
18 %else
19 Group: System Environment/Base
20 Provides: e2fsprogs-libs = %{version} ldiskfsprogs = %{version}
21 Obsoletes: e4fsprogs < %{version} e2fsprogs-libs < %{version}
22 %endif
23
24 %description
25 The e2fsprogs package contains a number of utilities for creating,
26 checking, modifying, and correcting any inconsistencies in ext2, ext3,
27 and ext4 filesystems.  E2fsprogs contains e2fsck (used to repair
28 filesystem inconsistencies after an unclean shutdown), mke2fs (used to
29 initialize a partition to contain an empty ext2 filesystem), debugfs
30 (used to examine the internal structure of a filesystem, to manually
31 repair a corrupted filesystem or to create test cases for e2fsck),
32 tune2fs (used to modify filesystem parameters), resize2fs to grow and
33 shrink unmounted ext2 filesystems, and most of the other core ext2fs
34 filesystem utilities.
35
36 You should install the e2fsprogs package if you are using any ext2,
37 ext3, or ext4 filesystems (if you're not sure, you probably should
38 install this package).  You may also need to install it (even if you
39 don't use ext2/ext3/ext4) for the libuuid and libblkid libraries and
40 fsck tool that are included here.
41
42 %package devel
43 Summary: Ext2 filesystem-specific static libraries and headers.
44 Group: Development/Libraries
45 Requires: e2fsprogs = %{version}
46
47 %description devel
48 E2fsprogs-devel contains the libraries and header files needed to
49 develop ext2, ext3, or ext4 filesystem-specific programs.
50
51 You should install e2fsprogs-devel if you want to develop
52 ext2. ext3. or ext4 filesystem-specific programs.  If you install
53 e2fsprogs-devel, you'll also want to install e2fsprogs.
54
55 %package -n uuidd
56 Summary: helper daemon to guarantee uniqueness of time-based UUIDs
57 Group: System Environment/Daemons
58 License: GPLv2
59 Requires: e2fsprogs = %{version}
60 Requires(pre): shadow-utils
61
62 %description -n uuidd
63 The uuidd package contains a userspace daemon (uuidd) which guarantees
64 uniqueness of time-based UUID generation even at very high rates on
65 SMP systems.
66
67 %prep
68 %setup
69
70 %build
71 %configure --enable-elf-shlibs --enable-nls --disable-defrag \
72         --enable-quota --disable-fuse2fs \
73         --without-libarchive \
74         %{?extra_config_flags:%extra_config_flags}
75 make
76 make check
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 export PATH=/sbin:$PATH
81 make install install-libs DESTDIR="$RPM_BUILD_ROOT" \
82         root_sbindir=%{_root_sbindir} root_libdir=%{_root_libdir}
83 /sbin/ldconfig -n ${RPM_BUILD_ROOT}%{_libdir}
84
85 # Add a dir that uuidd needs that the Makefiles don't create
86 install -d $RPM_BUILD_ROOT/var/lib/libuuid
87
88 %find_lang %{name}
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post -p /sbin/ldconfig
94
95 %postun -p /sbin/ldconfig
96
97 %post devel
98 if [ -x /sbin/install-info -a -f %{_infodir}/libext2fs.info.gz ]; then
99     /sbin/install-info %{_infodir}/libext2fs.info.gz %{_infodir}/dir
100 fi
101 exit 0
102
103 %postun devel
104 if [ $1 = 0 -a -x /sbin/install-info -a -f %{_infodir}/libext2fs.info.gz ]; then
105    /sbin/install-info --delete %{_infodir}/libext2fs.info.gz %{_infodir}/dir
106 fi
107 exit 0
108
109 %pre -n uuidd
110 getent group uuidd >/dev/null || groupadd -r uuidd
111 getent passwd uuidd >/dev/null || \
112 useradd -r -g uuidd -d /var/lib/libuuid -s /sbin/nologin \
113     -c "UUID generator helper daemon" uuidd
114 exit 0
115
116 %files -f %{name}.lang
117 %defattr(-,root,root)
118 %doc README RELEASE-NOTES
119
120 %{_root_sbindir}/badblocks
121 %{_root_sbindir}/blkid
122 %{_root_sbindir}/debugfs
123 %{_root_sbindir}/dumpe2fs
124 %{_root_sbindir}/e2fsck
125 %{_root_sbindir}/e2image
126 %{_root_sbindir}/e2label
127 %{_root_sbindir}/e2mmpstatus
128 %{_root_sbindir}/e2undo
129 %{_root_sbindir}/findfs
130 %{_root_sbindir}/fsck
131 %{_root_sbindir}/fsck.ext2
132 %{_root_sbindir}/fsck.ext3
133 %{_root_sbindir}/fsck.ext4
134 %{_root_sbindir}/fsck.ext4dev
135 %{_root_sbindir}/logsave
136 %{_root_sbindir}/mke2fs
137 %{_root_etcdir}/mke2fs.conf
138 %{_root_sbindir}/mkfs.ext2
139 %{_root_sbindir}/mkfs.ext3
140 %{_root_sbindir}/mkfs.ext4
141 %{_root_sbindir}/mkfs.ext4dev
142 %{_root_sbindir}/resize2fs
143 %{_root_sbindir}/tune2fs
144 %{_sbindir}/filefrag
145 %{_sbindir}/mklost+found
146 %{_sbindir}/e2freefrag
147
148 %{_root_libdir}/libblkid.so.*
149 %{_root_libdir}/libcom_err.so.*
150 %{_root_libdir}/libe2p.so.*
151 %{_root_libdir}/libext2fs.so.*
152 %{_root_libdir}/libss.so.*
153 %{_root_libdir}/libuuid.so.*
154
155 %{_libdir}/e2initrd_helper
156
157 %{_bindir}/chattr
158 %{_bindir}/lsattr
159 %{_bindir}/uuidgen
160 %{_mandir}/man1/chattr.1*
161 %{_mandir}/man1/lsattr.1*
162 %{_mandir}/man1/uuidgen.1*
163
164 %{_mandir}/man5/e2fsck.conf.5*
165 %{_mandir}/man5/mke2fs.conf.5*
166 %{_mandir}/man5/ext2.5*
167 %{_mandir}/man5/ext3.5*
168 %{_mandir}/man5/ext4.5*
169
170 %{_mandir}/man8/badblocks.8*
171 %{_mandir}/man8/blkid.8*
172 %{_mandir}/man8/debugfs.8*
173 %{_mandir}/man8/dumpe2fs.8*
174 %{_mandir}/man8/e2fsck.8*
175 %{_mandir}/man8/findfs.8*
176 %{_mandir}/man8/fsck.ext2.8*
177 %{_mandir}/man8/fsck.ext3.8*
178 %{_mandir}/man8/fsck.ext4.8*
179 %{_mandir}/man8/fsck.ext4dev.8*
180 %{_mandir}/man8/e2image.8*
181 %{_mandir}/man8/e2label.8*
182 %{_mandir}/man8/e2mmpstatus.8*
183 %{_mandir}/man8/e2undo.8*
184 %{_mandir}/man8/fsck.8*
185 %{_mandir}/man8/logsave.8*
186 %{_mandir}/man8/mke2fs.8*
187 %{_mandir}/man8/mkfs.ext2.8*
188 %{_mandir}/man8/mkfs.ext3.8*
189 %{_mandir}/man8/mkfs.ext4.8*
190 %{_mandir}/man8/mkfs.ext4dev.8*
191 %{_mandir}/man8/mklost+found.8*
192 %{_mandir}/man8/resize2fs.8*
193 %{_mandir}/man8/tune2fs.8*
194 %{_mandir}/man8/filefrag.8*
195 %{_mandir}/man8/e2freefrag.8*
196
197 %files devel
198 %defattr(-,root,root)
199 %{_infodir}/libext2fs.info*
200 %{_bindir}/compile_et
201 %{_bindir}/mk_cmds
202
203 %{_libdir}/libblkid.a
204 %{_libdir}/libblkid.so
205 %{_libdir}/libcom_err.a
206 %{_libdir}/libcom_err.so
207 %{_libdir}/libe2p.a
208 %{_libdir}/libe2p.so
209 %{_libdir}/libext2fs.a
210 %{_libdir}/libext2fs.so
211 %{_libdir}/libss.a
212 %{_libdir}/libss.so
213 %{_libdir}/libuuid.a
214 %{_libdir}/libuuid.so
215
216 %{_libdir}/pkgconfig/blkid.pc
217 %{_libdir}/pkgconfig/com_err.pc
218 %{_libdir}/pkgconfig/e2p.pc
219 %{_libdir}/pkgconfig/ext2fs.pc
220 %{_libdir}/pkgconfig/ss.pc
221 %{_libdir}/pkgconfig/uuid.pc
222
223 %{_datadir}/et
224 %{_datadir}/ss
225 %{_includedir}/blkid
226 %{_includedir}/e2p
227 %{_includedir}/et
228 %{_includedir}/com_err.h
229 %{_includedir}/ext2fs
230 %{_includedir}/ss
231 %{_includedir}/uuid
232 %{_mandir}/man1/compile_et.1*
233 %{_mandir}/man1/mk_cmds.1*
234 %{_mandir}/man3/com_err.3*
235 %{_mandir}/man3/libblkid.3*
236 %{_mandir}/man3/uuid.3*
237 %{_mandir}/man3/uuid_clear.3*
238 %{_mandir}/man3/uuid_compare.3*
239 %{_mandir}/man3/uuid_copy.3*
240 %{_mandir}/man3/uuid_generate.3*
241 %{_mandir}/man3/uuid_generate_random.3*
242 %{_mandir}/man3/uuid_generate_time.3*
243 %{_mandir}/man3/uuid_is_null.3*
244 %{_mandir}/man3/uuid_parse.3*
245 %{_mandir}/man3/uuid_time.3*
246 %{_mandir}/man3/uuid_unparse.3*
247
248 %files -n uuidd
249 %defattr(-,root,root)
250 # if you want to run via init
251 # /etc/init.d/uuidd
252 %{_mandir}/man8/uuidd.8*
253 %attr(6755, uuidd, uuidd) %{_sbindir}/uuidd
254 %dir %attr(2775, uuidd, uuidd) /var/lib/libuuid
255