Whamcloud - gitweb
New development branch for Lustre 2.14 2.13.50 v2_13_50
authorOleg Drokin <green@whamcloud.com>
Fri, 8 Nov 2019 16:47:17 +0000 (11:47 -0500)
committerOleg Drokin <green@whamcloud.com>
Fri, 8 Nov 2019 16:47:17 +0000 (11:47 -0500)
Change-Id: I5636e71d6618d23e72127c4154affec62718cdb4
Signed-off-by: Oleg Drokin <green@whamcloud.com>
LUSTRE-VERSION-GEN
lustre/ChangeLog

index 34fbebb..2270945 100755 (executable)
@@ -1,6 +1,6 @@
 #!/bin/sh
 
 #!/bin/sh
 
-DEFAULT_VERSION=2.12.58
+DEFAULT_VERSION=2.13.50
 LVF=LUSTRE-VERSION-FILE
 
 LF='
 LVF=LUSTRE-VERSION-FILE
 
 LF='
index a48156d..4039ef3 100644 (file)
@@ -1,4 +1,47 @@
 TBD Whamcloud
 TBD Whamcloud
+       * version 2.14.0
+       * See https://wiki.whamcloud.com/display/PUB/Lustre+Support+Matrix
+         for currently supported client and server kernel versions.
+       * Server primary kernels built and tested during release cycle:
+         3.10.0-1062.1.1.el7 (RHEL7.7)
+       * Other server kernels known to build and work at some point (others may also work):
+         3.10.0-862.14.4.el7 (RHEL7.5)
+         3.10.0-957.27.2.el7 (RHEL7.6)
+         4.18.0-80.7.1.el8   (RHEL8.0)
+         4.4.120-92.70       (SLES12 SP2)
+         4.4.180-94.100      (SLES12 SP3)
+         4.4.0-131           (Ubuntu 16.04)
+         4.15.0-32           (Ubuntu 18.04)
+         vanilla linux 4.6.7 (ZFS only)
+       * ldiskfs needs an ldiskfs patch series for that kernel, ZFS does not
+       * Client primary unpatched kernels built and tested during release cycle:
+         3.10.0-1062.1.1.el7 (RHEL7.7)
+         4.12.14-95.29       (SLES12 SP4)
+         4.15.0-48           (Ubuntu 18.04)
+       * Other clients known to build on unpatched kernels at some point (others may also work):
+         3.10.0-862.14.4.el7 (RHEL7.5)
+         3.10.0-957.27.2.el7 (RHEL7.6)
+         4.14.0-49.13.1.el7a (RHEL7.5)
+         4.14.0-115.2.2.el7a (RHEL7.6)
+         4.18.0-80.7.1.el8   (RHEL8.0)
+         4.4.120-92.70       (SLES12 SP2)
+         4.4.180-94.100      (SLES12 SP3)
+         4.4.0-131           (Ubuntu 16.04)
+         vanilla linux 4.15.0 (ZFS only)
+       * Recommended e2fsprogs version: 1.45.2.wc1 or newer
+       * Recommended ZFS / SPL version: 0.7.13
+       * NFS export disabled when stack size < 8192 (32-bit Lustre clients),
+         since the NFSv4 export of Lustre filesystem with 4K stack may cause a
+         stack overflow. For more information, please refer to bugzilla 17630.
+       * NFSv4 reexport to 32-bit NFS client nodes requires Lustre client on
+         the re-exporting nodes to be mounted with "32bitapi" mount option
+       * Note for Ubuntu 14.04.5:
+         The 4.4.0 series is the HWE Kernel derived from 16.04 (Xenial).
+         See: https://wiki.ubuntu.com/Kernel/LTSEnablementStack
+
+--------------------------------------------------------------------------------
+
+11-20-2019 Whamcloud
        * version 2.13.0
        * See https://wiki.whamcloud.com/display/PUB/Lustre+Support+Matrix
          for currently supported client and server kernel versions.
        * version 2.13.0
        * See https://wiki.whamcloud.com/display/PUB/Lustre+Support+Matrix
          for currently supported client and server kernel versions.