Whamcloud - gitweb
LU-13903 build: make lustre-devel buildable for Linux client 88/41188/2
authorJames Simmons <jsimmons@infradead.org>
Sat, 9 Jan 2021 15:24:16 +0000 (10:24 -0500)
committerOleg Drokin <green@whamcloud.com>
Fri, 26 Feb 2021 08:22:54 +0000 (08:22 +0000)
Recently a new lustre-devel rpm was created which always has a
dependency on the kernel detected by the kmod macros. This doesn't
work in the case of running a custom Linux kernel. Addreess this
by not making use of the kmod macros when only building the Lustre
utilies i.e configure --disable-modules.

Test-Parameters: trivial
Fixes: 16af4e5ed634 ("LU-9215 build: Re-add the lustre-devel package")
Signed-off-by: James Simmons <jsimmons@infradead.org>
Change-Id: I324fbaa0f5b03e2095b493f3d8e00b74ca64298a
Reviewed-on: https://review.whamcloud.com/41188
Tested-by: jenkins <devops@whamcloud.com>
Tested-by: Maloo <maloo@whamcloud.com>
Reviewed-by: Andreas Dilger <adilger@whamcloud.com>
Reviewed-by: Neil Brown <neilb@suse.de>
Reviewed-by: Oleg Drokin <green@whamcloud.com>
lustre.spec.in

index ef29b67..45d598b 100644 (file)
@@ -322,7 +322,9 @@ Summary: Lustre include headers
 Group: Development/Kernel
 Provides: lustre-devel = %{version}
 Requires: %{lustre_name} = %{version}
 Group: Development/Kernel
 Provides: lustre-devel = %{version}
 Requires: %{lustre_name} = %{version}
+%if %{with lustre_modules}
 Requires: %{requires_kmod_name} = %{requires_kmod_version}
 Requires: %{requires_kmod_name} = %{requires_kmod_version}
+%endif
 
 %description devel
 This package contains the header files needed for building additional
 
 %description devel
 This package contains the header files needed for building additional