Whamcloud - gitweb
LU-15967 build: configure script does not check for required build tools 44/47744/2
authorAlex Deiter <alex.deiter@gmail.com>
Fri, 24 Jun 2022 05:55:58 +0000 (22:55 -0700)
committerOleg Drokin <green@whamcloud.com>
Wed, 6 Jul 2022 03:33:33 +0000 (03:33 +0000)
- added check for flex and bison
- added requirement for build kernel modules

Change-Id: I4f4f19ea44f3cd8f69482d950970bf701e81f7ec
Signed-off-by: Alex Deiter <alex.deiter@gmail.com>
Reviewed-on: https://review.whamcloud.com/47744
Tested-by: jenkins <devops@whamcloud.com>
Reviewed-by: James Simmons <jsimmons@infradead.org>
Tested-by: Maloo <maloo@whamcloud.com>
Reviewed-by: Oleg Drokin <green@whamcloud.com>
config/lustre-build.m4
configure.ac

index 6a28127..fdae513 100644 (file)
@@ -155,6 +155,8 @@ AC_ARG_ENABLE([modules],
 AC_MSG_RESULT([$enable_modules ($target_os)])
 
 AS_IF([test "x$enable_modules" = xyes], [
 AC_MSG_RESULT([$enable_modules ($target_os)])
 
 AS_IF([test "x$enable_modules" = xyes], [
+       AS_IF([test "x$FLEX" = "x"], [AC_MSG_ERROR([flex package is required to build kernel modules])])
+       AS_IF([test "x$BISON" = "x"], [AC_MSG_ERROR([bison package is required to build kernel modules])])
        AS_CASE([$target_os],
                [linux*], [
                        # Run serial tests
        AS_CASE([$target_os],
                [linux*], [
                        # Run serial tests
index 16e9ee8..ea8aea7 100644 (file)
@@ -17,6 +17,8 @@ AC_PROG_LIBTOOL
 AC_PROG_MKDIR_P
 AM_PROG_AS
 
 AC_PROG_MKDIR_P
 AM_PROG_AS
 
+AC_PATH_PROG(FLEX, flex)
+AC_PATH_PROG(BISON, bison)
 AC_PATH_PROG(RPMBUILD, rpmbuild)
 AC_CHECK_TOOLS(AR, ar)
 
 AC_PATH_PROG(RPMBUILD, rpmbuild)
 AC_CHECK_TOOLS(AR, ar)