Whamcloud - gitweb
LU-11402 tests: add version check sanity-quota 60
[fs/lustre-release.git] / snmp / Makefile.am
index fe2a153..f7d114c 100644 (file)
@@ -1,7 +1,7 @@
-agent_PROGRAMS  = lustresnmp.so
+agent_LTLIBRARIES = liblustresnmp.la
 mib_DATA = Lustre-MIB.txt
 
-lustresnmp_so_SOURCES =                \
+liblustresnmp_la_SOURCES =     \
        lustre-snmp.c           \
        lustre-snmp.h           \
        lustre-snmp-trap.c      \
@@ -9,9 +9,11 @@ lustresnmp_so_SOURCES =                \
        lustre-snmp-util.c      \
        lustre-snmp-util.h
 
-lustresnmp_so_LDADD := $(NET_SNMP_LIBS)
-lustresnmp_so_CFLAGS := -fPIC $(NET_SNMP_CFLAGS)
-lustresnmp_so_LDFLAGS = -fPIC -shared
+LIBCFS = $(top_builddir)/libcfs/libcfs/libcfs.la
+
+liblustresnmp_la_CFLAGS := $(NET_SNMP_CFLAGS)
+liblustresnmp_la_LIBADD := $(NET_SNMP_LIBS) $(LIBCFS)
+liblustresnmp_la_LDFLAGS := -version-info 1:0:0
 
 SUBDIRS =
 DIST_SUBDIRS = autoconf