Whamcloud - gitweb
LU-7356 build: handle library configure options for SNMP/LNet
[fs/lustre-release.git] / snmp / Makefile.am
index c1ee04f..f616215 100644 (file)
@@ -1,7 +1,7 @@
-agent_PROGRAMS  := lustresnmp.so
-mib_DATA := Lustre-MIB.txt
+agent_LTLIBRARIES = liblustresnmp.la
+mib_DATA = Lustre-MIB.txt
 
-lustresnmp_so_SOURCES := \
+liblustresnmp_la_SOURCES =     \
        lustre-snmp.c           \
        lustre-snmp.h           \
        lustre-snmp-trap.c      \
@@ -9,11 +9,11 @@ lustresnmp_so_SOURCES := \
        lustre-snmp-util.c      \
        lustre-snmp-util.h
 
-lustresnmp_so_LDADD := $(NET_SNMP_LIBS)
-lustresnmp_so_CFLAGS := $(NET_SNMP_CFLAGS)
-lustresnmp_so_LDFLAGS := -fPIC -shared
+liblustresnmp_la_CFLAGS := $(NET_SNMP_CFLAGS)
+liblustresnmp_la_LIBADD := $(NET_SNMP_LIBS)
+liblustresnmp_la_LDFLAGS := -version-info 1:0:0
 
-SUBDIRS :=
-DIST_SUBDIRS := autoconf
+SUBDIRS =
+DIST_SUBDIRS = autoconf
 
-EXTRA_DIST := $(mib_DATA)
+EXTRA_DIST = $(mib_DATA)