Whamcloud - gitweb
LU-5278 echo: request pages in batches
[fs/lustre-release.git] / snmp / Makefile.am
index fe2a153..729031a 100644 (file)
@@ -1,7 +1,7 @@
-agent_PROGRAMS  = lustresnmp.so
+agent_LTLIBRARIES = lustresnmp.la
 mib_DATA = Lustre-MIB.txt
 
-lustresnmp_so_SOURCES =                \
+lustresnmp_la_SOURCES =                \
        lustre-snmp.c           \
        lustre-snmp.h           \
        lustre-snmp-trap.c      \
@@ -9,9 +9,9 @@ lustresnmp_so_SOURCES =         \
        lustre-snmp-util.c      \
        lustre-snmp-util.h
 
-lustresnmp_so_LDADD := $(NET_SNMP_LIBS)
-lustresnmp_so_CFLAGS := -fPIC $(NET_SNMP_CFLAGS)
-lustresnmp_so_LDFLAGS = -fPIC -shared
+lustresnmp_la_LIBADD := $(NET_SNMP_LIBS)
+lustresnmp_la_CFLAGS := -fPIC $(NET_SNMP_CFLAGS)
+lustresnmp_la_LDFLAGS = -fPIC -shared -module -avoid-version
 
 SUBDIRS =
 DIST_SUBDIRS = autoconf