Whamcloud - gitweb
LU-6030 ldiskfs: support pdirop split for RHEL6.5
[fs/lustre-release.git] / snmp / Makefile.am
index c1ee04f..729031a 100644 (file)
@@ -1,7 +1,7 @@
-agent_PROGRAMS  := lustresnmp.so
-mib_DATA := Lustre-MIB.txt
+agent_LTLIBRARIES = lustresnmp.la
+mib_DATA = Lustre-MIB.txt
 
-lustresnmp_so_SOURCES := \
+lustresnmp_la_SOURCES =                \
        lustre-snmp.c           \
        lustre-snmp.h           \
        lustre-snmp-trap.c      \
@@ -9,11 +9,11 @@ lustresnmp_so_SOURCES := \
        lustre-snmp-util.c      \
        lustre-snmp-util.h
 
-lustresnmp_so_LDADD := $(NET_SNMP_LIBS)
-lustresnmp_so_CFLAGS := $(NET_SNMP_CFLAGS)
-lustresnmp_so_LDFLAGS := -fPIC -shared
+lustresnmp_la_LIBADD := $(NET_SNMP_LIBS)
+lustresnmp_la_CFLAGS := -fPIC $(NET_SNMP_CFLAGS)
+lustresnmp_la_LDFLAGS = -fPIC -shared -module -avoid-version
 
-SUBDIRS :=
-DIST_SUBDIRS := autoconf
+SUBDIRS =
+DIST_SUBDIRS = autoconf
 
-EXTRA_DIST := $(mib_DATA)
+EXTRA_DIST = $(mib_DATA)