Whamcloud - gitweb
LU-2182 llapi: implementation of new llapi_layout API
[fs/lustre-release.git] / lustre / utils / Makefile.am
index 1c1bb4c..f56f1f7 100644 (file)
@@ -86,8 +86,8 @@ L_IOCTL := $(top_builddir)/libcfs/libcfs/util/l_ioctl.c
 L_KERNELCOMM := $(top_builddir)/libcfs/libcfs/kernel_user_comm.c
 liblustreapitmp_a_SOURCES = liblustreapi.c liblustreapi_hsm.c \
                            liblustreapi_nodemap.c lustreapi_internal.h \
-                           liblustreapi_json.c $(L_IOCTL) $(L_KERNELCOMM) \
-                           $(L_STRING)
+                           liblustreapi_json.c liblustreapi_layout.c \
+                           $(L_IOCTL) $(L_KERNELCOMM) $(L_STRING)
 
 # build static and shared lib lustreapi
 liblustreapi.a : liblustreapitmp.a