Whamcloud - gitweb
LU-1930 build: Back end file system fixes.
[fs/lustre-release.git] / lustre / utils / Makefile.am
index 5ab641d..e7c52a3 100644 (file)
@@ -130,7 +130,7 @@ endif
 if ZFS_ENABLED
 mount_lustre_SOURCES += mount_utils_zfs.c
 mount_lustre_CPPFLAGS = -DHAVE_IOCTL_IN_UNISTD_H
-mount_lustre_CPPFLAGS += -I /usr/include/libspl -I /usr/include/libzfs
+mount_lustre_CPPFLAGS += $(EXTRA_LIBZFS_INCLUDE)
 mount_lustre_LDFLAGS = -pthread -rdynamic -ldl
 endif
 
@@ -146,7 +146,7 @@ endif
 if ZFS_ENABLED
 mkfs_lustre_SOURCES += mount_utils_zfs.c
 mkfs_lustre_CPPFLAGS += -DHAVE_IOCTL_IN_UNISTD_H
-mkfs_lustre_CPPFLAGS += -I /usr/include/libspl -I /usr/include/libzfs
+mkfs_lustre_CPPFLAGS += $(EXTRA_LIBZFS_INCLUDE)
 mkfs_lustre_LDFLAGS = -pthread -rdynamic -ldl
 endif
 
@@ -160,7 +160,7 @@ endif
 if ZFS_ENABLED
 tunefs_lustre_SOURCES += mount_utils_zfs.c
 tunefs_lustre_CPPFLAGS += -DHAVE_IOCTL_IN_UNISTD_H
-tunefs_lustre_CPPFLAGS += -I /usr/include/libspl -I /usr/include/libzfs
+tunefs_lustre_CPPFLAGS += $(EXTRA_LIBZFS_INCLUDE)
 tunefs_lustre_LDFLAGS = -pthread -rdynamic -ldl
 endif