Whamcloud - gitweb
LU-6081 user: use random() instead of /dev/urandom
[fs/lustre-release.git] / lustre / utils / Makefile.am
index 69a07e3..bbb6b6e 100644 (file)
@@ -87,7 +87,7 @@ L_KERNELCOMM := $(top_builddir)/libcfs/libcfs/kernel_user_comm.c
 liblustreapitmp_a_SOURCES = liblustreapi.c liblustreapi_hsm.c \
                            liblustreapi_nodemap.c lustreapi_internal.h \
                            liblustreapi_json.c liblustreapi_layout.c \
-                           liblustreapi_lease.c \
+                           liblustreapi_lease.c liblustreapi_util.c \
                            $(L_IOCTL) $(L_KERNELCOMM) $(L_STRING)
 
 if UTILS
@@ -138,6 +138,7 @@ pkglib_LTLIBRARIES += mount_osd_ldiskfs.la
 
 mount_osd_ldiskfs_la_SOURCES = mount_utils_ldiskfs.c
 mount_osd_ldiskfs_la_LDFLAGS = -shared -export-dynamic -module -avoid-version
+mount_osd_ldiskfs_la_LIBADD := $(SELINUX)
 endif
 
 mount_lustre_SOURCES = mount_lustre.c mount_utils.c mount_utils.h