Whamcloud - gitweb
Need to include mount_utils.h in the _SOURCES for the tools that use it.
[fs/lustre-release.git] / lustre / utils / Makefile.am
index a7ee8f4..aa02674 100644 (file)
@@ -11,15 +11,16 @@ AM_LDFLAGS := -L$(top_builddir)/lnet/utils
 LIBPTLCTL := $(top_builddir)/lnet/utils/libptlctl.a
 
 sbin_scripts = lrun
-bin_scripts = llstat llobdstat plot-llstat 
+bin_scripts = llstat llobdstat plot-llstat llbackup
 
 if UTILS
-noinst_PROGRAMS = wirecheck wiretest obdio obdbarrier
+noinst_PROGRAMS = obdio obdbarrier
+EXTRA_PROGRAMS = wirecheck
 
 # mount only finds helpers in /sbin
 rootsbin_PROGRAMS = mount.lustre
-sbin_PROGRAMS = mkfs.lustre tunefs.lustre lctl \
-       l_getidentity l_facl llverfs llverdev \
+sbin_PROGRAMS = mkfs.lustre tunefs.lustre lctl wiretest \
+       l_getidentity llverfs llverdev \
        llog_reader lr_reader
 if LIBPTHREAD
 sbin_PROGRAMS += loadgen
@@ -79,11 +80,11 @@ llog_reader_DEPENDENCIES := $(LIBPTLCTL)
 
 lr_reader_SOURCES = lr_reader.c
 
-mount_lustre_SOURCES = mount_lustre.c 
+mount_lustre_SOURCES = mount_lustre.c mount_utils.c mount_utils.h
 mount_lustre_LDADD := $(LIBPTLCTL)
 mount_lustre_DEPENDENCIES := $(LIBPTLCTL)
 
-mkfs_lustre_SOURCES = mkfs_lustre.c
+mkfs_lustre_SOURCES = mkfs_lustre.c mount_utils.c mount_utils.h
 mkfs_lustre_CPPFLAGS = -UTUNEFS $(AM_CPPFLAGS)
 mkfs_lustre_LDADD := libiam.a $(LIBPTLCTL)
 mkfs_lustre_DEPENDENCIES := $(LIBPTLCTL) libiam.a
@@ -97,16 +98,12 @@ l_getidentity_SOURCES = l_getidentity.c
 l_getidentity_LDADD := $(LIBPTLCTL)
 l_getidentity_DEPENDENCIES := $(LIBPTLCTL)
 
-l_facl_SOURCES = l_facl.c
-l_facl_LDADD := liblustreapi.a
-l_facl_DEPENDENCIES := liblustreapi.a
-
 EXTRA_DIST = $(sbin_scripts) $(bin_scripts)
 
 # NOTE: this should only be run on i386.
 newwiretest: wirehdr.c wirecheck
        cp wirehdr.c wiretest.c
-       ./wirecheck >> wiretest.c
+       LANG=C ./wirecheck >> wiretest.c
        cp ../ptlrpc/wirehdr.c ../ptlrpc/wiretest.c
-       ./wirecheck >> ../ptlrpc/wiretest.c
+       LANG=C ./wirecheck >> ../ptlrpc/wiretest.c