Whamcloud - gitweb
LU-9897 build: use pkgconf for detecting libblkid
[fs/lustre-release.git] / lustre / utils / Makefile.am
index 75e6018..44ae523 100644 (file)
@@ -89,15 +89,8 @@ E2PLIB =
 EXT2FSLIB =
 endif
 
-if BLKID
-BLKIDLIB = -lblkid -luuid
-else
-BLKIDLIB =
-endif
-
 llverfs_LDADD := $(EXT2FSLIB) $(E2PLIB)
-
-llverdev_LDADD := $(EXT2FSLIB) $(BLKIDLIB)
+llverdev_LDADD := $(EXT2FSLIB) $(blkid_LIBS)
 
 liblustreapi_la_SOURCES = liblustreapi.c liblustreapi_hsm.c \
                          liblustreapi_nodemap.c lustreapi_internal.h \