Whamcloud - gitweb
Also comment out obdctl_SOURCES, otherwise it will fail to configure.
[fs/lustre-release.git] / lustre / utils / Makefile.am
index 2eb2a81..39b690f 100644 (file)
@@ -1,9 +1,14 @@
-DEFS:=
+# Administration utilities Makefile
+DEFS=
 
-CFLAGS:=-g -I. -I/usr/include/glib-1.2 -I$(PORTALS)/include \
+CFLAGS:=-g -O2 -I. -I/usr/include/libxml2 -I/usr/include/glib-1.2 -I$(PORTALS)/include \
 -I/usr/lib/glib/include -I$(srcdir)/../include -Wall
 KFLAGS:=
-CPPFLAGS :=
-LDADD := -lreadline -ltermcap # -lefence
-bin_PROGRAMS = obdctl
-obdctl_SOURCES = parser.c obdctl.c
+CPPFLAGS = $(HAVE_LIBREADLINE)
+obdctl_LDADD := $(LIBREADLINE) -lxml2 # -lefence
+lctl_LDADD := $(LIBREADLINE)
+sbin_PROGRAMS = lctl # obdctl
+#obdctl_SOURCES = parser.c obdctl.c parser.h
+lctl_SOURCES = parser.c network.c device.c debug.c lctl.c lctl.h parser.h
+
+include $(top_srcdir)/Rules