Whamcloud - gitweb
LU-10973 lnet: initial LUTF C infrastructure
[fs/lustre-release.git] / lustre / tests / Makefile.am
index 598435f..8353687 100644 (file)
@@ -3,6 +3,7 @@ AM_CFLAGS := -fPIC -D_GNU_SOURCE \
             -D_LARGEFILE64_SOURCE=1 -D_FILE_OFFSET_BITS=64
 
 DIST_SUBDIRS = mpi
+DIST_SUBDIRS += lutf
 
 noinst_DATA = disk2_4-ldiskfs.tar.bz2 disk2_4-zfs.tar.bz2
 noinst_DATA += disk2_7-ldiskfs.tar.bz2 disk2_7-zfs.tar.bz2
@@ -88,6 +89,15 @@ if MPITESTS
 SUBDIRS = mpi
 endif
 
+# Build LUTF only if the packages are available
+if BUILD_LUTF
+if MPITESTS
+SUBDIRS += lutf
+else
+SUBDIRS = lutf
+endif
+endif # BUILD_LUTF
+
 bin_PROGRAMS = mcreate munlink statx
 testdir = $(libdir)/lustre/tests
 test_SCRIPTS = $(noinst_SCRIPTS)