Whamcloud - gitweb
LU-11643 tests: revert new images and tests for upgrade patch
[fs/lustre-release.git] / lustre / tests / Makefile.am
index e32e353..7af3342 100644 (file)
@@ -2,8 +2,6 @@
 AM_CFLAGS := -fPIC -D_GNU_SOURCE \
             -D_LARGEFILE64_SOURCE=1 -D_FILE_OFFSET_BITS=64
 
-LIBLUSTREAPI = $(top_builddir)/lustre/utils/liblustreapi.la
-
 DIST_SUBDIRS = mpi
 
 noinst_DATA = disk1_8_up_2_5-ldiskfs.tar.bz2 disk2_1_up_2_5-ldiskfs.tar.bz2
@@ -37,11 +35,11 @@ noinst_SCRIPTS += sgpdd-survey.sh maloo_upload.sh auster setup-nfs.sh
 noinst_SCRIPTS += mds-survey.sh parallel-scale-nfs.sh large-lun.sh
 noinst_SCRIPTS += parallel-scale-nfsv3.sh parallel-scale-nfsv4.sh
 noinst_SCRIPTS += setup-cifs.sh parallel-scale-cifs.sh
-noinst_SCRIPTS += posix.sh sanity-scrub.sh scrub-performance.sh ha.sh
+noinst_SCRIPTS += posix.sh sanity-scrub.sh scrub-performance.sh ha.sh pjdfstest.sh
 noinst_SCRIPTS += sanity-lfsck.sh lfsck-performance.sh
 noinst_SCRIPTS += resolveip
 noinst_SCRIPTS += sanity-hsm.sh sanity-lsnapshot.sh sanity-pfl.sh sanity-flr.sh
-noinst_SCRIPTS += sanity-dom.sh dom-performance.sh
+noinst_SCRIPTS += sanity-dom.sh sanity-pcc.sh dom-performance.sh sanity-lnet.sh
 nobase_noinst_SCRIPTS = cfg/local.sh
 nobase_noinst_SCRIPTS += test-groups/regression test-groups/regression-mpi
 nobase_noinst_SCRIPTS += acl/make-tree acl/run cfg/ncli.sh
@@ -67,7 +65,7 @@ THETESTS = openunlink truncate directio writeme mlink utime
 THETESTS += tchmod fsx test_brw sendfile
 THETESTS += createmany chownmany statmany multifstat createtest
 THETESTS += opendirunlink opendevunlink unlinkmany checkstat
-THETESTS += statone runas openfile rmdirmany smalliomany
+THETESTS += statone runas openfile smalliomany
 THETESTS += small_write multiop ll_sparseness_verify
 THETESTS += ll_sparseness_write mrename ll_dirstripe_verify mkdirmany
 THETESTS += openfilleddirunlink rename_many memhog
@@ -76,7 +74,10 @@ THETESTS += write_time_limit rwv lgetxattr_size_check checkfiemap
 THETESTS += listxattr_size_check check_fhandle_syscalls badarea_io
 THETESTS += llapi_layout_test orphan_linkea_check llapi_hsm_test
 THETESTS += group_lock_test llapi_fid_test sendfile_grouplock mmap_cat
-THETESTS += swap_lock_test lockahead_test mirror_io
+THETESTS += swap_lock_test lockahead_test mirror_io mmap_mknod_test
+THETESTS += create_foreign_file parse_foreign_file
+THETESTS += create_foreign_dir parse_foreign_dir
+THETESTS += check_fallocate
 
 if TESTS
 if MPITESTS
@@ -90,9 +91,8 @@ test_PROGRAMS = $(THETESTS)
 nobase_test_SCRIPTS = $(nobase_noinst_SCRIPTS)
 test_DATA = $(noinst_DATA)
 nobase_test_DATA = $(nobase_noinst_DATA)
-else # !TESTS
-noinst_PROGRAMS = $(THETESTS)
-endif # TESTS
+
+LIBLUSTREAPI = $(top_builddir)/lustre/utils/liblustreapi.la
 
 mmap_sanity_LDADD = $(LIBLUSTREAPI)
 multiop_LDADD = $(LIBLUSTREAPI) $(PTHREAD_LIBS)
@@ -109,3 +109,6 @@ lockahead_test_LDADD = $(LIBLUSTREAPI)
 mirror_io_LDADD = $(LIBLUSTREAPI)
 ll_dirstripe_verify_LDADD = $(LIBLUSTREAPI)
 flocks_test_LDADD = $(LIBLUSTREAPI) $(PTHREAD_LIBS)
+create_foreign_dir_LDADD = $(LIBLUSTREAPI)
+check_fallocate_LDADD = $(LIBLUSTREAPI)
+endif # TESTS