Whamcloud - gitweb
- landing of b_hd_cleanup_merge to HEAD.
[fs/lustre-release.git] / lustre / tests / Makefile.am
index a74483c..5c603f7 100644 (file)
@@ -3,82 +3,44 @@ AM_CPPFLAGS = $(LLCPPFLAGS) -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
 AM_CFLAGS = $(LLCFLAGS)
 # LDADD = -lldap
 # LDADD := -lreadline -ltermcap # -lefence
-EXTRA_DIST = $(pkgexample_SCRIPTS) $(noinst_SCRIPTS) $(noinst_DATA) \
-       sanity.sh rundbench
-if TESTS
-pkgexample_SCRIPTS = llmount.sh llmountcleanup.sh llecho.sh llechocleanup.sh
-pkgexample_SCRIPTS += local.sh echo.sh uml.sh lov.sh
+
+pkgexample_scripts = llmount.sh llmountcleanup.sh llecho.sh llechocleanup.sh
+pkgexample_scripts += local.sh echo.sh uml.sh lov.sh
+
 noinst_DATA =
 noinst_SCRIPTS = leak_finder.pl llecho.sh llmount.sh llmountcleanup.sh tbox.sh
 noinst_SCRIPTS += llrmount.sh runfailure-mds runvmstat runfailure-net
 noinst_SCRIPTS += runfailure-ost runiozone runregression-net.sh runtests
 noinst_SCRIPTS += sanity.sh rundbench
+
+EXTRA_DIST = $(pkgexample_scripts) $(noinst_SCRIPTS) $(noinst_DATA) \
+       sanity.sh rundbench
+if TESTS
+pkgexample_SCRIPTS = $(pkgexample_scripts)
+
 noinst_PROGRAMS = openunlink testreq truncate directio openme writeme open_delay
 noinst_PROGRAMS += tchmod toexcl fsx test_brw openclose createdestroy
 noinst_PROGRAMS += stat createmany statmany multifstat createtest mlink utime
 noinst_PROGRAMS += opendirunlink opendevunlink unlinkmany fchdir_test checkstat
 noinst_PROGRAMS += wantedi statone runas openfile getdents mkdirdeep o_directory
 noinst_PROGRAMS += small_write multiop sleeptest ll_sparseness_verify cmknod
-noinst_PROGRAMS += ll_sparseness_write mrename ll_dirstripe_verify copy_attr
-noinst_PROGRAMS += openfilleddirunlink rename_many
-# noinst_PROGRAMS += ldaptest
-bin_PROGRAMS = mcreate munlink mkdirmany iopentest1 iopentest2
+
+noinst_PROGRAMS += ll_sparseness_write mrename ll_dirstripe_verify mkdirmany rmdirmany
+noinst_PROGRAMS += openfilleddirunlink rename_many memhog iopentest1 iopentest2
+noinst_PROGRAMS += mmap_sanity
+# noinst_PROGRAMS += ldaptest copy_attr
+bin_PROGRAMS = mcreate munlink
 endif # TESTS
 
 # ldaptest_SOURCES = ldaptest.c
-tchmod_SOURCES = tchmod.c
-toexcl_SOURCES = toexcl.c
-testreq_SOURCES = testreq.c
-mcreate_SOURCES = mcreate.c
-iopentest1_SOURCES = iopentest1.c
-iopentest2_SOURCES = iopentest2.c
-munlink_SOURCES = munlink.c
-mlink_SOURCES = mlink.c
-truncate_SOURCES = truncate.c
-directio_SOURCES = directio.c
-openunlink_SOURCES = openunlink.c
-openme_SOURCES = openme.c
-writeme_SOURCES = writeme.c
-fsx_SOURCES = fsx.c
-test_brw_SOURCES = test_brw.c
-openclose_SOURCES = openclose.c
-createdestroy_SOURCES = createdestroy.c
+
 stat_SOURCES = stat.c stat_fs.h
-createmany_SOURCES = createmany.c
-statmany_SOURCES = statmany.c
-unlinkmany_SOURCES = unlinkmany.c
-statone_SOURCES = statone.c
-mkdirmany_SOURCES = mkdirmany.c
-multifstat_SOURCES = multifstat.c
-checkstat_SOURCES = checkstat.c
-runas_SOURCES = runas.c
-openfile_SOURCES = openfile.c
-wantedi_SOURCES = wantedi.c
-createtest_SOURCES = createtest.c
-open_delay_SOURCES = open_delay.c
-opendirunlink_SOURCES = opendirunlink.c
-openfilleddirunlink_SOURCES = openfilleddirunlink.c
-opendevunlink_SOURCES = opendevunlink.c
-fchdir_test_SOURCES = fchdir_test.c
-getdents_SOURCES=getdents.c
-o_directory_SOURCES = o_directory.c
-utime_SOURCES = utime.c
-cmknod_SOURCES = cmknod.c
-mkdirdeep_SOURCES = mkdirdeep.c
 mkdirdeep_LDADD=-L$(top_builddir)/portals/utils -lptlctl $(LIBREADLINE)
-small_write_SOURCES = small_write.c
-sleeptest_SOURCES = sleeptest.c
-rename_many_SOURCES = rename_many.c
-#write_append_truncate_SOURCES=write_append_truncate.c
 #write_append_truncate_CC=mpicc
-#createmany_mpi_SOURCES=createmany_mpi.c
 #createmany_mpi_CC=mpicc
 #parallel_grouplock_SOURCES=parallel_grouplock.c lp_utils.c
 #parallel_grouplock_CC=mpicc
-copy_attr_SOURCES= copy_attr.c
-copy_attr_LDADD= -lattr
 
-#sanity test 
-ll_sparseness_verify_SOURCES = ll_sparseness_verify.c
-ll_sparseness_write_SOURCES = ll_sparseness_write.c
-ll_dirstripe_verify_SOURCE = ll_dirstripe_verify.c
+#copy_attr_LDADD= -lattr
+mmap_sanity_SOURCES= mmap_sanity.c
+