Whamcloud - gitweb
LU-10752 build: properly package lsvcgss for rpm builds
[fs/lustre-release.git] / lustre / scripts / Makefile.am
index 4f8f253..f834235 100644 (file)
 #
 # You should have received a copy of the GNU General Public License
 # version 2 along with this program; If not, see
-# http://www.sun.com/software/products/lustre/docs/GPLv2.pdf
-#
-# Please contact Sun Microsystems, Inc., 4150 Network Circle, Santa Clara,
-# CA 95054 USA or visit www.sun.com if you need additional information or
-# have any questions.
+# http://www.gnu.org/licenses/gpl-2.0.html
 #
 # GPL HEADER END
 #
 #
 
 # These are scripts that are generated from .in files
-genscripts = lc_modprobe lc_net lc_hb lc_cluman lc_md lc_lvm lustre_start
+genscripts = lc_modprobe lc_net lc_hb lc_cluman lc_md lc_lvm lustre_start lnet
+
+SUBDIRS = systemd
 
 sbin_SCRIPTS = lustre_rmmod ko2iblnd-probe
 
 if RHEL
 initdir = $(sysconfdir)/init.d
-init_SCRIPTS  = lnet
+init_SCRIPTS  =
+
+if !HAVE_SYSTEMD
+init_SCRIPTS += lnet
+endif
+
 if SERVER
 init_SCRIPTS += lustre
+if GSS_KEYRING
+init_SCRIPTS += lsvcgss
+endif
 endif
 endif
 
@@ -60,6 +66,11 @@ bin_SCRIPTS  += lustre_req_history
 hadir = $(sysconfdir)/ha.d/resource.d
 ha_SCRIPTS = Lustre.ha_v2
 
+if ZFS_ENABLED
+zedletdir = $(sysconfdir)/zfs/zed.d/
+zedlet_SCRIPTS = statechange-lustre.sh
+endif
+
 scriptlibdir = @libexecdir@/@PACKAGE@
 scriptlib_SCRIPTS = haconfig
 scriptlib_DATA = lc_common
@@ -71,15 +82,15 @@ endif
 
 endif # UTILS
 
-EXTRA_DIST = license-status version_tag.pl version_tag-git.pl \
-            version_tag-none.pl lustre_rmmod ldev lc_mon lhbadm \
+EXTRA_DIST = license-status lustre_rmmod ldev lc_mon lhbadm \
             lc_servip lustre_routes_config lustre_routes_conversion \
             $(addsuffix .in,$(genscripts)) lfs_migrate lustre_req_history \
-            lustre lnet lc_common haconfig Lustre.ha_v2 dkms.mkconf \
-            zfsobj2fid ko2iblnd-probe
+            lustre lsvcgss lc_common haconfig Lustre.ha_v2 dkms.mkconf \
+            zfsobj2fid ko2iblnd-probe statechange-lustre.sh
 
 CLEANFILES = $(genscripts)
 
 $(genscripts): %: %.in
-       sed -e 's#@scriptlibdir@#$(scriptlibdir)#' < $< > $@
+       sed -e 's,@sysconfdir\@,$(sysconfdir),g' \
+           -e 's,@scriptlibdir\@,$(scriptlibdir),g' $< > $@
        chmod +x $@