Whamcloud - gitweb
Branch HEAD
[fs/lustre-release.git] / lustre / scripts / Makefile.am
index a33c1e5..f0a44a3 100644 (file)
@@ -3,8 +3,23 @@
 # This code is issued under the GNU General Public License.
 # See the file COPYING in this distribution
 
-EXTRA_DIST = license-status maketags.sh lustre.spec $(initd_SCRIPTS)
-initddir = $(sysconfdir)/init.d
-initd_SCRIPTS = lustre
-include $(top_srcdir)/Rules
+sbinscripts = lc_servip lustre_up14 lustre_rmmod
 
+# These are scripts that are generated from .in files
+genscripts = lustre_config lc_modprobe lc_net lc_hb lc_cluman lustre_createcsv lc_md lc_lvm
+
+sbin_SCRIPTS = $(genscripts) $(sbinscripts)
+bin_SCRIPTS = lustre_req_history
+
+EXTRA_DIST = license-status maketags.sh version_tag.pl.in lc_common \
+            $(addsuffix .in,$(genscripts)) lc_mon $(sbinscripts) \
+            $(bin_SCRIPTS)
+
+scriptlibdir = $(libdir)/@PACKAGE@
+scriptlib_DATA = lc_common
+
+CLEANFILES = $(genscripts)
+
+$(genscripts): %: %.in
+       sed -e 's#@scriptlibdir@#$(scriptlibdir)#' < $< > $@
+       chmod +x $@