Whamcloud - gitweb
Branch HEAD
[fs/lustre-release.git] / lustre / scripts / Makefile.am
index 5e57916..f0a44a3 100644 (file)
@@ -3,11 +3,23 @@
 # This code is issued under the GNU General Public License.
 # See the file COPYING in this distribution
 
-EXTRA_DIST = license-status maketags.sh lustre.spec version_tag.pl.in  \
-       $(initd_SCRIPTS) lustre.spec.in lustre-kernel-2.4.spec.in       \
-       lmake linux-merge-config.awk linux-merge-modules.awk            \
-       linux-rhconfig.h
+sbinscripts = lc_servip lustre_up14 lustre_rmmod
 
-initddir = $(sysconfdir)/init.d
-initd_SCRIPTS = lustre
+# These are scripts that are generated from .in files
+genscripts = lustre_config lc_modprobe lc_net lc_hb lc_cluman lustre_createcsv lc_md lc_lvm
 
+sbin_SCRIPTS = $(genscripts) $(sbinscripts)
+bin_SCRIPTS = lustre_req_history
+
+EXTRA_DIST = license-status maketags.sh version_tag.pl.in lc_common \
+            $(addsuffix .in,$(genscripts)) lc_mon $(sbinscripts) \
+            $(bin_SCRIPTS)
+
+scriptlibdir = $(libdir)/@PACKAGE@
+scriptlib_DATA = lc_common
+
+CLEANFILES = $(genscripts)
+
+$(genscripts): %: %.in
+       sed -e 's#@scriptlibdir@#$(scriptlibdir)#' < $< > $@
+       chmod +x $@