Whamcloud - gitweb
LU-12734 misc: add bash completion for lctl set/get_param
[fs/lustre-release.git] / lustre / scripts / Makefile.am
index f834235..bbb1cc7 100644 (file)
@@ -82,11 +82,17 @@ endif
 
 endif # UTILS
 
+if ENABLE_BASH_COMPLETION
+bashcompletiondir = $(BASH_COMPLETION_DIR)
+dist_bashcompletion_DATA = bash-completion/lctl
+endif
+
 EXTRA_DIST = license-status lustre_rmmod ldev lc_mon lhbadm \
             lc_servip lustre_routes_config lustre_routes_conversion \
             $(addsuffix .in,$(genscripts)) lfs_migrate lustre_req_history \
             lustre lsvcgss lc_common haconfig Lustre.ha_v2 dkms.mkconf \
-            zfsobj2fid ko2iblnd-probe statechange-lustre.sh
+            zfsobj2fid ko2iblnd-probe statechange-lustre.sh \
+            bash-completion/lctl
 
 CLEANFILES = $(genscripts)