Whamcloud - gitweb
LU-13069 obdclass: don't skip records for wrapped catalog
[fs/lustre-release.git] / lustre / scripts / Makefile.am
index 3757519..bbb1cc7 100644 (file)
@@ -48,9 +48,7 @@ init_SCRIPTS += lnet
 endif
 
 if SERVER
-if !HAVE_SYSTEMD
 init_SCRIPTS += lustre
-endif
 if GSS_KEYRING
 init_SCRIPTS += lsvcgss
 endif
@@ -84,11 +82,17 @@ endif
 
 endif # UTILS
 
+if ENABLE_BASH_COMPLETION
+bashcompletiondir = $(BASH_COMPLETION_DIR)
+dist_bashcompletion_DATA = bash-completion/lctl
+endif
+
 EXTRA_DIST = license-status lustre_rmmod ldev lc_mon lhbadm \
             lc_servip lustre_routes_config lustre_routes_conversion \
             $(addsuffix .in,$(genscripts)) lfs_migrate lustre_req_history \
-            lsvcgss lc_common haconfig Lustre.ha_v2 dkms.mkconf \
-            zfsobj2fid ko2iblnd-probe statechange-lustre.sh
+            lustre lsvcgss lc_common haconfig Lustre.ha_v2 dkms.mkconf \
+            zfsobj2fid ko2iblnd-probe statechange-lustre.sh \
+            bash-completion/lctl
 
 CLEANFILES = $(genscripts)