Whamcloud - gitweb
LU-2950 lnet: Add a mechanism to configure routes from a file
[fs/lustre-release.git] / lustre / scripts / Makefile.am
index 19fc744..b35463f 100644 (file)
 #
 
 sbinscripts = lc_servip lustre_up14 lustre_rmmod lhbadm ldev
+sbinscripts += lustre_routes_config lustre_routes_conversion
 
 # These are scripts that are generated from .in files
 genscripts = lustre_config lc_modprobe lc_net lc_hb lc_cluman lustre_createcsv \
-    lc_md lc_lvm lustre_start lustre
+    lc_md lc_lvm lustre_start
 
 initdir = $(sysconfdir)/init.d
 init_SCRIPTS = lustre lnet
 
 hadir = $(sysconfdir)/ha.d/resource.d
-ha_SCRIPTS = Lustre
+ha_SCRIPTS = Lustre.ha_v2
 
 sbin_SCRIPTS = $(genscripts) $(sbinscripts)
 bin_SCRIPTS = lustre_req_history lfs_migrate
@@ -52,8 +53,8 @@ bin_SCRIPTS = lustre_req_history lfs_migrate
 EXTRA_DIST = license-status maketags.sh version_tag.pl version_tag-git.pl \
             version_tag-cvs.pl version_tag-none.pl lc_common \
             $(addsuffix .in,$(genscripts)) lc_mon $(sbinscripts) \
-            $(bin_SCRIPTS) make_META.pl lustre.in lnet lhbadm \
-            haconfig ldev Lustre
+            $(bin_SCRIPTS) make_META.pl lustre lnet lhbadm \
+            haconfig ldev Lustre.ha_v2
 
 scriptlibdir = @libexecdir@/@PACKAGE@
 scriptlib_SCRIPTS = haconfig