Whamcloud - gitweb
LU-1305 lprocfs: osd-ldiskfs to use common helpers
[fs/lustre-release.git] / lustre / scripts / Makefile.am
index 4904457..9b00685 100644 (file)
@@ -25,7 +25,7 @@
 #
 
 #
-# Copyright  2008 Sun Microsystems, Inc. All rights reserved
+# Copyright (c) 1999, 2010, Oracle and/or its affiliates. All rights reserved.
 # Use is subject to license terms.
 #
 
@@ -41,13 +41,14 @@ genscripts = lustre_config lc_modprobe lc_net lc_hb lc_cluman lustre_createcsv \
     lc_md lc_lvm lustre_start
 
 sbin_SCRIPTS = $(genscripts) $(sbinscripts)
-bin_SCRIPTS = lustre_req_history
+bin_SCRIPTS = lustre_req_history lfs_migrate
 
-EXTRA_DIST = license-status maketags.sh version_tag.pl lc_common \
+EXTRA_DIST = license-status maketags.sh version_tag.pl version_tag-git.pl \
+            version_tag-cvs.pl version_tag-none.pl lc_common \
             $(addsuffix .in,$(genscripts)) lc_mon $(sbinscripts) \
-            $(bin_SCRIPTS) tree_status.pl
+            $(bin_SCRIPTS) make_META.pl
 
-scriptlibdir = $(libdir)/@PACKAGE@
+scriptlibdir = @libexecdir@/@PACKAGE@
 scriptlib_DATA = lc_common
 
 CLEANFILES = $(genscripts)
@@ -56,5 +57,5 @@ $(genscripts): %: %.in
        sed -e 's#@scriptlibdir@#$(scriptlibdir)#' < $< > $@
        chmod +x $@
 
-tree_status.pl: version_tag.pl
-       ln -f version_tag.pl tree_status.pl
+make_META.pl: version_tag.pl
+       ln -f $< $@