Whamcloud - gitweb
LU-9439 scripts: lnet systemd service
[fs/lustre-release.git] / lustre / scripts / Makefile.am
index 395bcf2..9267a81 100644 (file)
 #
 # You should have received a copy of the GNU General Public License
 # version 2 along with this program; If not, see
-# http://www.sun.com/software/products/lustre/docs/GPLv2.pdf
-#
-# Please contact Sun Microsystems, Inc., 4150 Network Circle, Santa Clara,
-# CA 95054 USA or visit www.sun.com if you need additional information or
-# have any questions.
+# http://www.gnu.org/licenses/gpl-2.0.html
 #
 # GPL HEADER END
 #
@@ -28,6 +24,8 @@
 # Copyright (c) 1999, 2010, Oracle and/or its affiliates. All rights reserved.
 # Use is subject to license terms.
 #
+# Copyright (c) 2013, 2015, Intel Corporation.
+#
 
 #
 # This file is part of Lustre, http://www.lustre.org/
 # These are scripts that are generated from .in files
 genscripts = lc_modprobe lc_net lc_hb lc_cluman lc_md lc_lvm lustre_start
 
-sbin_SCRIPTS = lustre_rmmod
+SUBDIRS = systemd
+
+sbin_SCRIPTS = lustre_rmmod ko2iblnd-probe
 
-if INIT_SCRIPTS
+if RHEL
 initdir = $(sysconfdir)/init.d
-init_SCRIPTS  = lnet
+init_SCRIPTS  = lsvcgss
+
+if !HAVE_SYSTEMD
+init_SCRIPTS += lnet
+endif
+
 if SERVER
 init_SCRIPTS += lustre
 endif
@@ -62,13 +67,18 @@ scriptlibdir = @libexecdir@/@PACKAGE@
 scriptlib_SCRIPTS = haconfig
 scriptlib_DATA = lc_common
 endif # SERVER
+
+if ZFS_ENABLED
+sbin_SCRIPTS += zfsobj2fid
+endif
+
 endif # UTILS
 
-EXTRA_DIST = license-status version_tag.pl version_tag-git.pl \
-            version_tag-none.pl lustre_rmmod ldev lc_mon lhbadm \
+EXTRA_DIST = license-status lustre_rmmod ldev lc_mon lhbadm \
             lc_servip lustre_routes_config lustre_routes_conversion \
             $(addsuffix .in,$(genscripts)) lfs_migrate lustre_req_history \
-            lustre lnet lc_common haconfig Lustre.ha_v2 dkms.mkconf
+            lustre lnet lsvcgss lc_common haconfig Lustre.ha_v2 dkms.mkconf \
+            zfsobj2fid ko2iblnd-probe
 
 CLEANFILES = $(genscripts)