Whamcloud - gitweb
Branch HEAD
[fs/lustre-release.git] / lustre / scripts / Makefile.am
index 3d556fb..8eebb58 100644 (file)
@@ -14,8 +14,8 @@
 # in the LICENSE file that accompanied this code).
 #
 # You should have received a copy of the GNU General Public License
-# version 2 along with this program; If not, see [sun.com URL with a
-# copy of GPLv2].
+# version 2 along with this program; If not, see
+# http://www.sun.com/software/products/lustre/docs/GPLv2.pdf
 #
 # Please contact Sun Microsystems, Inc., 4150 Network Circle, Santa Clara,
 # CA 95054 USA or visit www.sun.com if you need additional information or
 sbinscripts = lc_servip lustre_up14 lustre_rmmod
 
 # These are scripts that are generated from .in files
-genscripts = lustre_config lc_modprobe lc_net lc_hb lc_cluman lustre_createcsv lc_md lc_lvm
+genscripts = lustre_config lc_modprobe lc_net lc_hb lc_cluman lustre_createcsv \
+    lc_md lc_lvm lustre_start
 
 sbin_SCRIPTS = $(genscripts) $(sbinscripts)
 bin_SCRIPTS = lustre_req_history
 
-EXTRA_DIST = license-status maketags.sh version_tag.pl.in lc_common \
+EXTRA_DIST = license-status maketags.sh version_tag.pl lc_common \
             $(addsuffix .in,$(genscripts)) lc_mon $(sbinscripts) \
-            $(bin_SCRIPTS)
+            $(bin_SCRIPTS) tree_status.pl
 
 scriptlibdir = $(libdir)/@PACKAGE@
 scriptlib_DATA = lc_common
@@ -54,3 +55,6 @@ CLEANFILES = $(genscripts)
 $(genscripts): %: %.in
        sed -e 's#@scriptlibdir@#$(scriptlibdir)#' < $< > $@
        chmod +x $@
+
+tree_status.pl: version_tag.pl
+       ln version_tag.pl tree_status.pl