Whamcloud - gitweb
LU-4277 scripts: ofd status integrated with zpool status
[fs/lustre-release.git] / lustre / scripts / Makefile.am
index 9267a81..8b52188 100644 (file)
@@ -33,7 +33,7 @@
 #
 
 # These are scripts that are generated from .in files
-genscripts = lc_modprobe lc_net lc_hb lc_cluman lc_md lc_lvm lustre_start
+genscripts = lc_modprobe lc_net lc_hb lc_cluman lc_md lc_lvm lustre_start lnet
 
 SUBDIRS = systemd
 
@@ -63,6 +63,11 @@ bin_SCRIPTS  += lustre_req_history
 hadir = $(sysconfdir)/ha.d/resource.d
 ha_SCRIPTS = Lustre.ha_v2
 
+if ZFS_ENABLED
+zedletdir = $(sysconfdir)/zfs/zed.d/
+zedlet_SCRIPTS = statechange-lustre.sh
+endif
+
 scriptlibdir = @libexecdir@/@PACKAGE@
 scriptlib_SCRIPTS = haconfig
 scriptlib_DATA = lc_common
@@ -77,11 +82,12 @@ endif # UTILS
 EXTRA_DIST = license-status lustre_rmmod ldev lc_mon lhbadm \
             lc_servip lustre_routes_config lustre_routes_conversion \
             $(addsuffix .in,$(genscripts)) lfs_migrate lustre_req_history \
-            lustre lnet lsvcgss lc_common haconfig Lustre.ha_v2 dkms.mkconf \
-            zfsobj2fid ko2iblnd-probe
+            lustre lsvcgss lc_common haconfig Lustre.ha_v2 dkms.mkconf \
+            zfsobj2fid ko2iblnd-probe statechange-lustre.sh
 
 CLEANFILES = $(genscripts)
 
 $(genscripts): %: %.in
-       sed -e 's#@scriptlibdir@#$(scriptlibdir)#' < $< > $@
+       sed -e 's,@sysconfdir\@,$(sysconfdir),g' \
+           -e 's,@scriptlibdir\@,$(scriptlibdir),g' $< > $@
        chmod +x $@