Whamcloud - gitweb
LU-1935 scripts: don't generate lustre init script
[fs/lustre-release.git] / lustre / scripts / Makefile.am
index 5a6ea9c..04f9ee2 100644 (file)
@@ -1,16 +1,69 @@
-# Copyright (C) 2001  Cluster File Systems, Inc.
 #
-# This code is issued under the GNU General Public License.
-# See the file COPYING in this distribution
+# GPL HEADER START
+#
+# DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License version 2 only,
+# as published by the Free Software Foundation.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# General Public License version 2 for more details (a copy is included
+# in the LICENSE file that accompanied this code).
+#
+# You should have received a copy of the GNU General Public License
+# version 2 along with this program; If not, see
+# http://www.sun.com/software/products/lustre/docs/GPLv2.pdf
+#
+# Please contact Sun Microsystems, Inc., 4150 Network Circle, Santa Clara,
+# CA 95054 USA or visit www.sun.com if you need additional information or
+# have any questions.
+#
+# GPL HEADER END
+#
+
+#
+# Copyright (c) 1999, 2010, Oracle and/or its affiliates. All rights reserved.
+# Use is subject to license terms.
+#
+
+#
+# This file is part of Lustre, http://www.lustre.org/
+# Lustre is a trademark of Sun Microsystems, Inc.
+#
+
+sbinscripts = lc_servip lustre_up14 lustre_rmmod lhbadm ldev
+
+# These are scripts that are generated from .in files
+genscripts = lustre_config lc_modprobe lc_net lc_hb lc_cluman lustre_createcsv \
+    lc_md lc_lvm lustre_start
+
+initdir = $(sysconfdir)/init.d
+init_SCRIPTS = lustre lnet
+
+hadir = $(sysconfdir)/ha.d/resource.d
+ha_SCRIPTS = Lustre
+
+sbin_SCRIPTS = $(genscripts) $(sbinscripts)
+bin_SCRIPTS = lustre_req_history lfs_migrate
+
+EXTRA_DIST = license-status maketags.sh version_tag.pl version_tag-git.pl \
+            version_tag-cvs.pl version_tag-none.pl lc_common \
+            $(addsuffix .in,$(genscripts)) lc_mon $(sbinscripts) \
+            $(bin_SCRIPTS) make_META.pl lustre lnet lhbadm \
+            haconfig ldev Lustre
 
-EXTRA_DIST = license-status maketags.sh lustre.spec version_tag.pl.in  \
-       lustre lustrefs lustre.spec.in lustre-kernel-2.4.spec.in       \
-       lmake linux-merge-config.awk linux-merge-modules.awk            \
-       linux-rhconfig.h
+scriptlibdir = @libexecdir@/@PACKAGE@
+scriptlib_SCRIPTS = haconfig
+scriptlib_DATA = lc_common
 
-initddir = $(sysconfdir)/init.d
-if UTILS
-initd_SCRIPTS = lustre lustrefs
-endif
+CLEANFILES = $(genscripts)
 
+$(genscripts): %: %.in
+       sed -e 's#@scriptlibdir@#$(scriptlibdir)#' < $< > $@
+       chmod +x $@
 
+make_META.pl: version_tag.pl
+       ln -f $< $@