Whamcloud - gitweb
landing b_cmobd_merge on HEAD
[fs/lustre-release.git] / lustre / portals / utils / Makefile.am
index e871d9a..a14df1c 100644 (file)
@@ -3,26 +3,29 @@
 # This code is issued under the GNU General Public License.
 # See the file COPYING in this distribution
 
-# ../ for <portals/*.h>, ../../ for <config.h>
-COMPILE = $(CC) -Wall -g -I$(srcdir)/../include -I$(srcdir)/../../include
-LINK = $(CC) -o $@
+## $(srcdir)/../ for <portals/*.h>, ../../ for generated <config.h>
+#COMPILE = $(CC) -Wall -g -I$(srcdir)/../include -I../../include
+#LINK = $(CC) -o $@
 
 if LIBLUSTRE
-
 noinst_LIBRARIES = libuptlctl.a
-libuptlctl_a_SOURCES = portals.c debug.c l_ioctl.c parser.c parser.h
-libuptlctl_a_CFLAGS = -fPIC
+libuptlctl_a_SOURCES = portals.c debug.c l_ioctl.c
+libuptlctl_a_CPPFLAGS = $(LLCPPFLAGS)
+libuptlctl_a_CFLAGS = $(LLCFLAGS)
+endif
 
-else
+sbin_PROGRAMS = debugctl
 
-sbin_PROGRAMS = acceptor ptlctl debugctl routerstat wirecheck gmnalnid
 lib_LIBRARIES = libptlctl.a
 
-acceptor_SOURCES = acceptor.c # -lefence
+libptlctl_a_SOURCES = portals.c debug.c l_ioctl.c parser.c parser.h
+
+if !CRAY_PORTALS
+sbin_PROGRAMS += acceptor ptlctl routerstat wirecheck gmnalnid
 
-wirecheck_SOURCES = wirecheck.c
+acceptor_SOURCES = acceptor.c
 
-libptlctl_a_SOURCES = portals.c debug.c l_ioctl.c parser.c parser.h
+wirecheck_SOURCES = wirecheck.c
 
 gmnalnid_SOURCES = gmnalnid.c
 
@@ -30,9 +33,10 @@ ptlctl_SOURCES = ptlctl.c
 ptlctl_LDADD =  -L. -lptlctl $(LIBREADLINE) $(LIBEFENCE)
 ptlctl_DEPENDENCIES = libptlctl.a
 
+routerstat_SOURCES = routerstat.c
+endif
+
 debugctl_SOURCES = debugctl.c
 debugctl_LDADD = -L. -lptlctl $(LIBREADLINE) $(LIBEFENCE)
 debugctl_DEPENDENCIES = libptlctl.a
 
-routerstat_SOURCES = routerstat.c
-endif