Whamcloud - gitweb
Lproc-snmp code drop
[fs/lustre-release.git] / lustre / ost / Makefile.am
index 31965cb..3ad390a 100644 (file)
@@ -3,14 +3,22 @@
 # This code is issued under the GNU General Public License.
 # See the file COPYING in this distribution
 
+DEFS= 
 MODULE = ost
 modulefs_DATA = ost.o
 EXTRA_PROGRAMS = ost
 
+LINX=obd_pack.c ll_pack.c target.c
+
+ll_pack.c: 
+       test -e ll_pack.c || ln -sf $(top_srcdir)/lib/ll_pack.c
 obd_pack.c: 
-       ln -s ../lib/obd_pack.c .
+       test -e obd_pack.c || ln -sf $(top_srcdir)/lib/obd_pack.c
+target.c: 
+       test -e target.c || ln -sf $(top_srcdir)/lib/target.c
 
-ost_SOURCES = obd_pack.c handler.c 
+ost_SOURCES = ost_handler.c lproc_ost.c $(LINX)
+dist-hook:
+       list='$(LINX)'; for f in $$list; do rm -f $(distdir)/$$f; done
 
 include $(top_srcdir)/Rules
-