Whamcloud - gitweb
landing b_cmobd_merge on HEAD
[fs/lustre-release.git] / lustre / osc / autoMakefile.am
similarity index 58%
rename from lustre/osc/Makefile.am
rename to lustre/osc/autoMakefile.am
index 0cb3bcd..dae803a 100644 (file)
@@ -3,17 +3,16 @@
 # This code is issued under the GNU General Public License.
 # See the file COPYING in this distribution
 
-DEFS=
-
 if LIBLUSTRE
 noinst_LIBRARIES = libosc.a
 libosc_a_SOURCES = osc_request.c osc_lib.c osc_create.c osc_internal.h
-libosc_a_CFLAGS = -fPIC
-else
-MODULE = osc
-modulefs_DATA = osc.o
-EXTRA_PROGRAMS = osc
-osc_SOURCES = osc_request.c lproc_osc.c osc_lib.c  osc_create.c osc_internal.h
+libosc_a_CPPFLAGS = $(LLCPPFLAGS)
+libosc_a_CFLAGS = $(LLCFLAGS)
+endif
+
+if MODULES
+modulefs_DATA = osc$(KMODEXT)
 endif
 
-include $(top_srcdir)/Rules
+MOSTLYCLEANFILES = *.o *.ko *.mod.c
+DIST_SOURCES = $(osc-objs:%.o=%.c) osc_internal.h