Whamcloud - gitweb
More makefile fixes.
[fs/lustre-release.git] / lustre / osc / Makefile.am
index 769b5dd..5c0557e 100644 (file)
@@ -3,20 +3,21 @@
 # This code is issued under the GNU General Public License.
 # See the file COPYING in this distribution
 
-DEFS:=
+DEFS=
 
 MODULE = osc
 modulefs_DATA = osc.o
 EXTRA_PROGRAMS = osc
 
-LINX= obd_pack.c ll_pack.c
-osc_SOURCES =  obd_pack.c osc_request.c # super.c rw.c file.c dir.c sysctl.c super.c namei.c symlink.c
+LINX= obd_pack.c ll_pack.c client.c
+osc_SOURCES = osc_request.c $(LINX)
 
 obd_pack.c: 
        test -e obd_pack.c || ln -sf $(top_srcdir)/lib/obd_pack.c
-
 ll_pack.c: 
        test -e ll_pack.c || ln -sf $(top_srcdir)/lib/ll_pack.c
+client.c: 
+       test -e client.c || ln -sf $(top_srcdir)/lib/client.c
 
 dist-hook:
        list='$(LINX)'; for f in $$list; do rm -f $(distdir)/$$f; done