Whamcloud - gitweb
land 0.5.20.3 b_devel onto HEAD (b_devel will remain)
[fs/lustre-release.git] / lustre / osc / Makefile.am
index 284c2d6..19fd65c 100644 (file)
@@ -5,17 +5,21 @@
 
 DEFS=
 
+
+if LIBLUSTRE
+lib_LIBRARIES = libosc.a
+LINX= obd_pack.c client.c
+libosc_a_SOURCES = osc_request.c  $(LINX)
+else
 MODULE = osc
 modulefs_DATA = osc.o
 EXTRA_PROGRAMS = osc
-
-LINX= obd_pack.c ll_pack.c client.c
+LINX= obd_pack.c client.c
 osc_SOURCES = osc_request.c lproc_osc.c $(LINX)
+endif
 
 obd_pack.c: 
        test -e obd_pack.c || ln -sf $(top_srcdir)/lib/obd_pack.c
-ll_pack.c: 
-       test -e ll_pack.c || ln -sf $(top_srcdir)/lib/ll_pack.c
 client.c: 
        test -e client.c || ln -sf $(top_srcdir)/lib/client.c