Whamcloud - gitweb
smash the HEAD with the contents of b_cmd. HEAD_PRE_CMD_SMASH and
[fs/lustre-release.git] / lustre / osc / Makefile.am
similarity index 58%
rename from lustre/osc/autoMakefile.am
rename to lustre/osc/Makefile.am
index dae803a..0cb3bcd 100644 (file)
@@ -3,16 +3,17 @@
 # This code is issued under the GNU General Public License.
 # See the file COPYING in this distribution
 
+DEFS=
+
 if LIBLUSTRE
 noinst_LIBRARIES = libosc.a
 libosc_a_SOURCES = osc_request.c osc_lib.c osc_create.c osc_internal.h
-libosc_a_CPPFLAGS = $(LLCPPFLAGS)
-libosc_a_CFLAGS = $(LLCFLAGS)
-endif
-
-if MODULES
-modulefs_DATA = osc$(KMODEXT)
+libosc_a_CFLAGS = -fPIC
+else
+MODULE = osc
+modulefs_DATA = osc.o
+EXTRA_PROGRAMS = osc
+osc_SOURCES = osc_request.c lproc_osc.c osc_lib.c  osc_create.c osc_internal.h
 endif
 
-MOSTLYCLEANFILES = *.o *.ko *.mod.c
-DIST_SOURCES = $(osc-objs:%.o=%.c) osc_internal.h
+include $(top_srcdir)/Rules