Whamcloud - gitweb
Fix symlinks when building a new tree outside the source tree.
[fs/lustre-release.git] / lustre / obdfilter / Makefile.am
index 4567bb9..f4c98f7 100644 (file)
@@ -10,7 +10,7 @@ EXTRA_PROGRAMS = obdfilter
 
 LINX=simple.c
 simple.c: 
-       ln -s ../lib/simple.c .
+       test -e simple.c || ln -sf $(top_srcdir)/lib/simple.c
 
 EXT2C = filter.c
 obdfilter_SOURCES = filter.c $(LINX)