Whamcloud - gitweb
Lproc-snmp code drop
[fs/lustre-release.git] / lustre / obdfilter / Makefile.am
index f4c98f7..a237004 100644 (file)
@@ -3,17 +3,20 @@
 # This code is issued under the GNU General Public License.
 # See the file COPYING in this distribution
 
-DEFS:
+DEFS= 
 MODULE = obdfilter
 modulefs_DATA = obdfilter.o
 EXTRA_PROGRAMS = obdfilter
 
-LINX=simple.c
-simple.c: 
+LINX=simple.c ll_pack.c
+ll_pack.c:
+       test -e ll_pack.c || ln -sf $(top_srcdir)/lib/ll_pack.c
+
+simple.c:
        test -e simple.c || ln -sf $(top_srcdir)/lib/simple.c
 
-EXT2C = filter.c
-obdfilter_SOURCES = filter.c $(LINX)
+FILTERC = filter.c lproc_obdfilter.c
+obdfilter_SOURCES = $(FILTERC) $(LINX)
 
 dist-hook:
        list='$(LINX)'; for f in $$list; do rm -f $(distdir)/$$f; done