Whamcloud - gitweb
Lproc-snmp code drop
[fs/lustre-release.git] / lustre / obdfilter / Makefile.am
index 054cb16..a237004 100644 (file)
@@ -3,18 +3,19 @@
 # This code is issued under the GNU General Public License.
 # See the file COPYING in this distribution
 
-DEFS:
+DEFS= 
 MODULE = obdfilter
 modulefs_DATA = obdfilter.o
 EXTRA_PROGRAMS = obdfilter
 
-LINX=page.c simple.c
+LINX=simple.c ll_pack.c
+ll_pack.c:
+       test -e ll_pack.c || ln -sf $(top_srcdir)/lib/ll_pack.c
+
 simple.c:
        test -e simple.c || ln -sf $(top_srcdir)/lib/simple.c
-page.c:
-       test -e page.c || ln -sf $(top_srcdir)/lib/page.c
 
-FILTERC = filter.c
+FILTERC = filter.c lproc_obdfilter.c
 obdfilter_SOURCES = $(FILTERC) $(LINX)
 
 dist-hook: