Whamcloud - gitweb
- merge 0.7rc1 from b_devel to HEAD (20030612 merge point)
[fs/lustre-release.git] / lustre / obdecho / Makefile.am
index 8539f01..08136d7 100644 (file)
@@ -4,12 +4,16 @@
 # See the file COPYING in this distribution
 
 DEFS= 
+
+if LIBLUSTRE
+lib_LIBRARIES = libobdecho.a
+libobdecho_a_SOURCES = echo_client.c 
+else
 MODULE = obdecho
 modulefs_DATA = obdecho.o
 EXTRA_PROGRAMS = obdecho
-
 LINX=
-obdecho_SOURCES = echo.c $(LINX)
+obdecho_SOURCES = echo.c echo_client.c lproc_echo.c $(LINX)
+endif
 
 include $(top_srcdir)/Rules
-