Whamcloud - gitweb
- merge 0.7rc1 from b_devel to HEAD (20030612 merge point)
[fs/lustre-release.git] / lustre / obdclass / Makefile.am
index fb04cc1..7b7c5b9 100644 (file)
@@ -1,18 +1,17 @@
-
 # FIXME: we need to make it clear that obdclass.o depends on
 # lustre_build_version, or 'make -j2' breaks!
 DEFS=
 MODULE = obdclass
 
-if LINUX25
-FSMOD = fsfilt_ext3
-else
+if EXTN
 FSMOD = fsfilt_extN
+else
+FSMOD = fsfilt_ext3
 endif
 
 if LIBLUSTRE
 lib_LIBRARIES = liblustreclass.a
-liblustreclass_a_SOURCES = uuid.c statfs_pack.c genops.c debug.c class_obd.c lustre_handles.c lustre_peer.c lprocfs_status.c
+liblustreclass_a_SOURCES = uuid.c statfs_pack.c genops.c debug.c class_obd.c lustre_handles.c lustre_peer.c lprocfs_status.c simple.c
 
 class_obd.o: lustre_version
 
@@ -24,7 +23,8 @@ else
 modulefs_DATA = lustre_build_version obdclass.o $(FSMOD).o fsfilt_reiserfs.o
 EXTRA_PROGRAMS = obdclass $(FSMOD) fsfilt_reiserfs
 
-obdclass_SOURCES = class_obd.c debug.c genops.c sysctl.c uuid.c lprocfs_status.c lustre_handles.c lustre_peer.c
+obdclass_SOURCES = class_obd.c debug.c genops.c sysctl.c uuid.c simple.c
+obdclass_SOURCES += lprocfs_status.c lustre_handles.c lustre_peer.c
 obdclass_SOURCES += fsfilt.c statfs_pack.c
 endif
 
@@ -33,7 +33,7 @@ include $(top_srcdir)/Rules
 # XXX I'm sure there's some automake mv-if-different helper for this.
 lustre_build_version:
        perl $(top_srcdir)/scripts/version_tag.pl $(top_srcdir) $(top_builddir) > tmpver
-       cmp -z $(top_builddir)/include/linux/lustre_build_version.h tmpver \
+       cmp -s $(top_builddir)/include/linux/lustre_build_version.h tmpver \
                2> /dev/null &&                                            \
                $(RM) tmpver ||                                            \
                mv tmpver $(top_builddir)/include/linux/lustre_build_version.h