Whamcloud - gitweb
merge b_devel into HEAD, which will become 0.7.3
[fs/lustre-release.git] / lustre / obdclass / Makefile.am
index 61f4bc2..06d60d4 100644 (file)
@@ -1,5 +1,3 @@
-# FIXME: we need to make it clear that obdclass.o depends on
-# lustre_build_version, or 'make -j2' breaks!
 DEFS=
 MODULE = obdclass
 
@@ -9,15 +7,13 @@ else
 FSMOD = fsfilt_ext3
 endif
 
+class_obd.o: lustre_build_version
+
 if LIBLUSTRE
 lib_LIBRARIES = liblustreclass.a
-liblustreclass_a_SOURCES = uuid.c statfs_pack.c genops.c debug.c class_obd.c lustre_handles.c lustre_peer.c lprocfs_status.c simple.c
-
-class_obd.o: lustre_version
-
-lustre_version:
-       echo '#define LUSTRE_VERSION 12' > $(top_builddir)/include/linux/lustre_build_version.h
-       echo '#define BUILD_VERSION "1"' >> $(top_builddir)/include/linux/lustre_build_version.h
+liblustreclass_a_SOURCES = uuid.c statfs_pack.c genops.c debug.c class_obd.c
+liblustreclass_a_SOURCES += lustre_handles.c lustre_peer.c lprocfs_status.c
+liblustreclass_a_SOURCES += simple.c recov_log.c obdo.c
 
 else
 modulefs_DATA = lustre_build_version obdclass.o $(FSMOD).o fsfilt_reiserfs.o
@@ -25,15 +21,16 @@ EXTRA_PROGRAMS = obdclass $(FSMOD) fsfilt_reiserfs
 
 obdclass_SOURCES = class_obd.c debug.c genops.c sysctl.c uuid.c simple.c
 obdclass_SOURCES += lprocfs_status.c lustre_handles.c lustre_peer.c
-obdclass_SOURCES += fsfilt.c statfs_pack.c otree.c
+obdclass_SOURCES += fsfilt.c statfs_pack.c otree.c recov_log.c obdo.c
 endif
 
 include $(top_srcdir)/Rules
 
-# XXX I'm sure there's some automake mv-if-different helper for this.
 lustre_build_version:
        perl $(top_srcdir)/scripts/version_tag.pl $(top_srcdir) $(top_builddir) > tmpver
+       echo #define LUSTRE_RELEASE @RELEASE@ >> tmpver
        cmp -s $(top_builddir)/include/linux/lustre_build_version.h tmpver \
-               2> /dev/null &&                                            \
-               $(RM) tmpver ||                                            \
-               mv tmpver $(top_builddir)/include/linux/lustre_build_version.h
+                2> /dev/null &&                                            \
+                $(RM) tmpver ||                                            \
+                mv tmpver $(top_builddir)/include/linux/lustre_build_version.h
+