Whamcloud - gitweb
Merge b_md into HEAD
[fs/lustre-release.git] / lustre / mds / Makefile.am
index 8c94e54..f789c22 100644 (file)
@@ -3,23 +3,22 @@
 # This code is issued under the GNU General Public License.
 # See the file COPYING in this distribution
 
-DEFS:
+DEFS= 
 
 MODULE = mds
-modulefs_DATA = mds.o mds_ext2.o mds_ext3.o mds_extN.o
-EXTRA_PROGRAMS = mds mds_ext2 mds_ext3 mds_extN
 
-LINX=mds_updates.c simple.c
+modulefs_DATA = mds.o
+EXTRA_PROGRAMS = mds
+
+LINX= mds_updates.c mds_open.c simple.c target.c
+
 mds_updates.c: 
        test -e mds_updates.c || ln -sf $(top_srcdir)/lib/mds_updates.c
-
 simple.c: 
        test -e simple.c || ln -sf $(top_srcdir)/lib/simple.c
+target.c: 
+       test -e target.c || ln -sf $(top_srcdir)/lib/target.c
 
-mds_SOURCES = handler.c mds_reint.c mds_fs.c $(LINX)
-
-dist-hook:
-       list='$(LINX)'; for f in $$list; do rm -f $(distdir)/$$f; done
+mds_SOURCES = mds_lov.c handler.c mds_reint.c mds_fs.c lproc_mds.c $(LINX)
 
 include $(top_srcdir)/Rules
-