Whamcloud - gitweb
- fix make dist
[fs/lustre-release.git] / lustre / mds / Makefile.am
index c81056b..f5fb932 100644 (file)
@@ -3,16 +3,27 @@
 # This code is issued under the GNU General Public License.
 # See the file COPYING in this distribution
 
-DEFS= 
+DEFS:
 
 MODULE = mds
-modulefs_DATA = mds.o
-EXTRA_PROGRAMS = mds
+modulefs_DATA = mds.o mds_extN.o # mds_ext2.o mds_ext3.o
+EXTRA_PROGRAMS = mds mds_extN # mds_ext2 mds_ext3
 
-mds_pack.c: 
-       ln -s ../lib/mds_pack.c .
+LINX=mds_updates.c simple.c ll_pack.c l_net.c
+ll_pack.c: 
+       test -e ll_pack.c || ln -sf $(top_srcdir)/lib/ll_pack.c
+
+mds_updates.c: 
+       test -e mds_updates.c || ln -sf $(top_srcdir)/lib/mds_updates.c
+
+simple.c: 
+       test -e simple.c || ln -sf $(top_srcdir)/lib/simple.c
+
+l_net.c: 
+       test -e l_net.c || ln -sf $(top_srcdir)/lib/l_net.c
+
+mds_SOURCES = handler.c mds_reint.c mds_fs.c $(LINX)
 
-mds_SOURCES = mds_pack.c handler.c 
 
 include $(top_srcdir)/Rules