Whamcloud - gitweb
Merge b_md to HEAD for 0.5.19 release.
[fs/lustre-release.git] / lustre / mds / Makefile.am
index f5fb932..12f06fc 100644 (file)
@@ -3,27 +3,22 @@
 # This code is issued under the GNU General Public License.
 # See the file COPYING in this distribution
 
-DEFS:
+DEFS= 
 
 MODULE = mds
-modulefs_DATA = mds.o mds_extN.o # mds_ext2.o mds_ext3.o
-EXTRA_PROGRAMS = mds mds_extN # mds_ext2 mds_ext3
 
-LINX=mds_updates.c simple.c ll_pack.c l_net.c
-ll_pack.c: 
-       test -e ll_pack.c || ln -sf $(top_srcdir)/lib/ll_pack.c
+modulefs_DATA = mds.o
+EXTRA_PROGRAMS = mds
+
+LINX= mds_updates.c simple.c target.c
 
 mds_updates.c: 
        test -e mds_updates.c || ln -sf $(top_srcdir)/lib/mds_updates.c
-
 simple.c: 
        test -e simple.c || ln -sf $(top_srcdir)/lib/simple.c
+target.c: 
+       test -e target.c || ln -sf $(top_srcdir)/lib/target.c
 
-l_net.c: 
-       test -e l_net.c || ln -sf $(top_srcdir)/lib/l_net.c
-
-mds_SOURCES = handler.c mds_reint.c mds_fs.c $(LINX)
-
+mds_SOURCES = mds_lov.c handler.c mds_reint.c mds_fs.c lproc_mds.c $(LINX)
 
 include $(top_srcdir)/Rules
-