Whamcloud - gitweb
Don't LBUG if we get bad stripe data back from the MDS (normally a bug, but
[fs/lustre-release.git] / lustre / mdc / Makefile.am
index 6fffd8a..f4f0218 100644 (file)
@@ -3,18 +3,17 @@
 # This code is issued under the GNU General Public License.
 # See the file COPYING in this distribution
 
-DEFS:=
+DEFS=
 
+if LIBLUSTRE
+lib_LIBRARIES = libmdc.a
+libmdc_a_SOURCES = mdc_request.c mdc_reint.c mdc_lib.c mdc_internal.h
+else
 MODULE = mdc
 modulefs_DATA = mdc.o
 EXTRA_PROGRAMS = mdc
 
-
-mdc_SOURCES =  mds_pack.c mdc_request.c mdc_reint.c mds_updates.c
-
-mds_pack.c: 
-       ln -s ../lib/mds_pack.c .
-mds_updates.c: 
-       ln -s ../lib/mds_updates.c .
+mdc_SOURCES = mdc_request.c mdc_reint.c lproc_mdc.c mdc_lib.c mdc_internal.h
+endif
 
 include $(top_srcdir)/Rules