Whamcloud - gitweb
Tweak autogen.sh and Makefiles to be compatible with Automake 1.6.2.
[fs/lustre-release.git] / lustre / mdc / Makefile.am
index 4069f6b..48e416c 100644 (file)
@@ -3,20 +3,19 @@
 # This code is issued under the GNU General Public License.
 # See the file COPYING in this distribution
 
-DEFS:=
+DEFS=
 
 MODULE = mdc
 modulefs_DATA = mdc.o
 EXTRA_PROGRAMS = mdc
 
-LINX=mds_updates.c
+LINX=mds_updates.c ll_pack.c
 mdc_SOURCES =  mdc_request.c mdc_reint.c $(LINX)
+ll_pack.c: 
+       test -e ll_pack.c || ln -sf $(top_srcdir)/lib/ll_pack.c .
 
 mds_updates.c: 
        test -e mds_updates.c || ln -sf $(top_srcdir)/lib/mds_updates.c .
 
-dist-hook:
-       list='$(LINX)'; for f in $$list; do rm -f $(distdir)/$$f; done
-
 
 include $(top_srcdir)/Rules