Whamcloud - gitweb
Fix symlinks when building a new tree outside the source tree.
[fs/lustre-release.git] / lustre / mdc / Makefile.am
index c2d0321..4069f6b 100644 (file)
@@ -9,14 +9,11 @@ MODULE = mdc
 modulefs_DATA = mdc.o
 EXTRA_PROGRAMS = mdc
 
-
-LINX=mds_pack.c mds_updates.c
+LINX=mds_updates.c
 mdc_SOURCES =  mdc_request.c mdc_reint.c $(LINX)
 
-mds_pack.c: 
-       ln -s ../lib/mds_pack.c .
 mds_updates.c: 
-       ln -s ../lib/mds_updates.c .
+       test -e mds_updates.c || ln -sf $(top_srcdir)/lib/mds_updates.c .
 
 dist-hook:
        list='$(LINX)'; for f in $$list; do rm -f $(distdir)/$$f; done