Whamcloud - gitweb
Fix symlinks when building a new tree outside the source tree.
[fs/lustre-release.git] / lustre / mdc / Makefile.am
index 1595d3d..4069f6b 100644 (file)
@@ -13,7 +13,7 @@ LINX=mds_updates.c
 mdc_SOURCES =  mdc_request.c mdc_reint.c $(LINX)
 
 mds_updates.c: 
-       ln -s ../lib/mds_updates.c .
+       test -e mds_updates.c || ln -sf $(top_srcdir)/lib/mds_updates.c .
 
 dist-hook:
        list='$(LINX)'; for f in $$list; do rm -f $(distdir)/$$f; done