Whamcloud - gitweb
Lproc-snmp code drop
[fs/lustre-release.git] / lustre / mdc / Makefile.am
index 65234e6..26c0053 100644 (file)
@@ -3,16 +3,23 @@
 # This code is issued under the GNU General Public License.
 # See the file COPYING in this distribution
 
-DEFS:=
+DEFS=
 
 MODULE = mdc
 modulefs_DATA = mdc.o
 EXTRA_PROGRAMS = mdc
 
+LINX= mds_updates.c ll_pack.c lov_pack.c client.c
+mdc_SOURCES =  mdc_request.c mdc_reint.c lproc_mdc.c $(LINX)
 
-mdc_SOURCES =  mds_pack.c mdc_request.c 
+lov_pack.c: 
+       test -e lov_pack.c || ln -sf $(top_srcdir)/lib/lov_pack.c .
+ll_pack.c: 
+       test -e ll_pack.c || ln -sf $(top_srcdir)/lib/ll_pack.c .
+mds_updates.c: 
+       test -e mds_updates.c || ln -sf $(top_srcdir)/lib/mds_updates.c .
+client.c: 
+       test -e client.c || ln -sf $(top_srcdir)/lib/client.c .
 
-mds_pack.c: 
-       ln -s ../lib/mds_pack.c .
 
 include $(top_srcdir)/Rules